summaryrefslogtreecommitdiff
path: root/dev-perl/Apache-Test
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-perl/Apache-Test
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-perl/Apache-Test')
-rw-r--r--dev-perl/Apache-Test/Apache-Test-1.420.0-r1.ebuild (renamed from dev-perl/Apache-Test/Apache-Test-1.420.0.ebuild)66
-rw-r--r--dev-perl/Apache-Test/Apache-Test-1.430.0.ebuild105
-rw-r--r--dev-perl/Apache-Test/Manifest4
3 files changed, 134 insertions, 41 deletions
diff --git a/dev-perl/Apache-Test/Apache-Test-1.420.0.ebuild b/dev-perl/Apache-Test/Apache-Test-1.420.0-r1.ebuild
index ba9954835c5c..84866d81da25 100644
--- a/dev-perl/Apache-Test/Apache-Test-1.420.0.ebuild
+++ b/dev-perl/Apache-Test/Apache-Test-1.420.0-r1.ebuild
@@ -1,11 +1,13 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
DIST_AUTHOR=SHAY
+# Parallel tests seem to be bad.
+DIST_TEST="do"
DIST_VERSION=1.42
-inherit depend.apache perl-module
+inherit depend.apache optfeature perl-module
DESCRIPTION="Test.pm wrapper with helpers for testing Apache"
@@ -15,7 +17,7 @@ KEYWORDS="amd64 ~arm ~ia64 ~mips ppc ppc64 sparc x86"
IUSE="test"
RESTRICT="!test? ( test )"
-DEPEND="virtual/perl-ExtUtils-MakeMaker"
+BDEPEND="virtual/perl-ExtUtils-MakeMaker"
need_apache
@@ -28,38 +30,7 @@ pkg_setup() {
perl_set_version
}
-src_install() {
- # This is to avoid conflicts with a deprecated Apache::Test stepping
- # in and causing problems/install errors
- if [ -f "${S}"/.mypacklist ];
- then
- rm -f "${S}"/.mypacklist
- fi
- perl-module_src_install
-}
-# Parallel tests seem to be bad.
-DIST_TEST="do"
-
-optdep_notice() {
- local i
- elog "This package has several modules which may require additional dependencies"
- elog "to use. However, it is up to you to install them separately if you need this"
- elog "optional functionality:"
- elog
- i="$(if has_version 'www-apache/mod_perl'; then echo '[I]'; else echo '[ ]'; fi)"
- elog " $i www-apache/mod_perl"
- elog " - Running Perl code natively in Apache via"
- elog " Apache::TestHandler, Apache::TestReportPerl, or Apache::TestSmokePerl"
-
- if use test; then
- elog
- elog "This module will perform additional tests if these dependencies are"
- elog "pre-installed"
- fi
-}
src_test() {
- optdep_notice
- echo
local MODULES=(
"Apache::Test ${DIST_VERSION}"
"Apache::Test5005compat 0.01"
@@ -92,28 +63,43 @@ src_test() {
"Apache::TestUtil 0.02"
"Bundle::ApacheTest ${DISTVERSION}"
)
+
has_version "www-apache/mod_perl" && MODULES+=(
"Apache::TestHandler"
"Apache::TestReportPerl"
"Apache::TestSmokePerl"
)
+
local failed=()
+
for dep in "${MODULES[@]}"; do
ebegin "Compile testing ${dep}"
- perl -Mblib="${S}" -M"${dep} ()" -e1
+ perl -Mblib="${S}" -M"${dep} ()" -e1
eend $? || failed+=( "$dep" )
done
+
if [[ ${failed[@]} ]]; then
- echo
- eerror "One or more modules failed compile:";
+ eerror "One or more modules failed compile:"
for dep in "${failed[@]}"; do
eerror " ${dep}"
done
- die "Failing due to module compilation errors";
+ die "Failing due to module compilation errors"
fi
+
perl_rm_files t/more/02testmore.t t/more/04testmore.t
perl-module_src_test
}
+
+src_install() {
+ # This is to avoid conflicts with a deprecated Apache::Test stepping
+ # in and causing problems/install errors
+ if [[ -f "${S}"/.mypacklist ]]; then
+ rm -f "${S}"/.mypacklist
+ fi
+
+ perl-module_src_install
+}
+
pkg_postinst() {
- use test || optdep_notice
+ optfeature "Running Perl code natively in Apache via Apache::TestHandler, Apache::TestReportPerl, or Apache::TestSmokePerl" www-apache/mod_perl
}
diff --git a/dev-perl/Apache-Test/Apache-Test-1.430.0.ebuild b/dev-perl/Apache-Test/Apache-Test-1.430.0.ebuild
new file mode 100644
index 000000000000..30bdf451170c
--- /dev/null
+++ b/dev-perl/Apache-Test/Apache-Test-1.430.0.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=SHAY
+# Parallel tests seem to be bad.
+DIST_TEST="do"
+DIST_VERSION=1.43
+inherit depend.apache optfeature perl-module
+
+DESCRIPTION="Test.pm wrapper with helpers for testing Apache"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="virtual/perl-ExtUtils-MakeMaker"
+
+need_apache
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.400.0-catfile-import.patch"
+ "${FILESDIR}/${PN}-1.400.0-phpclient.patch"
+)
+
+pkg_setup() {
+ perl_set_version
+}
+
+src_test() {
+ local MODULES=(
+ "Apache::Test ${DIST_VERSION}"
+ "Apache::Test5005compat 0.01"
+ "Apache::TestBuild"
+ "Apache::TestClient"
+ "Apache::TestCommon"
+ "Apache::TestCommonPost"
+ "Apache::TestConfig"
+ "Apache::TestConfigC"
+ "Apache::TestConfigPHP"
+ "Apache::TestConfigParrot"
+ "Apache::TestConfigParse"
+ "Apache::TestConfigPerl"
+ "Apache::TestHarness"
+ "Apache::TestHarnessPHP"
+ "Apache::TestMB"
+ "Apache::TestMM"
+ "Apache::TestPerlDB"
+ "Apache::TestReport"
+ "Apache::TestRequest"
+ "Apache::TestRun"
+ "Apache::TestRunPHP 1.00"
+ "Apache::TestRunParrot 1.00"
+ "Apache::TestRunPerl 1.00"
+ "Apache::TestSSLCA"
+ "Apache::TestServer"
+ "Apache::TestSmoke"
+ "Apache::TestSort"
+ "Apache::TestTrace 0.01"
+ "Apache::TestUtil 0.02"
+ "Bundle::ApacheTest ${DISTVERSION}"
+ )
+
+ has_version "www-apache/mod_perl" && MODULES+=(
+ "Apache::TestHandler"
+ "Apache::TestReportPerl"
+ "Apache::TestSmokePerl"
+ )
+
+ local failed=()
+
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1
+ eend $? || failed+=( "$dep" )
+ done
+
+ if [[ ${failed[@]} ]]; then
+ eerror "One or more modules failed compile:"
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors"
+ fi
+
+ perl_rm_files t/more/02testmore.t t/more/04testmore.t
+ perl-module_src_test
+}
+
+src_install() {
+ # This is to avoid conflicts with a deprecated Apache::Test stepping
+ # in and causing problems/install errors
+ if [[ -f "${S}"/.mypacklist ]]; then
+ rm -f "${S}"/.mypacklist
+ fi
+
+ perl-module_src_install
+}
+
+pkg_postinst() {
+ optfeature "Running Perl code natively in Apache via Apache::TestHandler, Apache::TestReportPerl, or Apache::TestSmokePerl" www-apache/mod_perl
+}
diff --git a/dev-perl/Apache-Test/Manifest b/dev-perl/Apache-Test/Manifest
index 845344bb6618..569022ea37d8 100644
--- a/dev-perl/Apache-Test/Manifest
+++ b/dev-perl/Apache-Test/Manifest
@@ -1,5 +1,7 @@
AUX Apache-Test-1.400.0-catfile-import.patch 813 BLAKE2B eda9f0dcfae5025d94f3c126e61258a920e8b0a475fb147bd61a96676aa8211c0d70e3aa5a37976603bb67c3d5a93e27feb0735456523bdf7c8706dbb254b730 SHA512 2c7807a0e69652b58f8d5297ac5e24f90ae3e453a3025dc441afef0134eed7dd0d78728dfce47a15c93c498f6e70404b1a79df07de55b376ae267453ba0b990b
AUX Apache-Test-1.400.0-phpclient.patch 909 BLAKE2B f109642536a1253245e55332e084b9c82fe4b72368cc34b4097889cd31358de4b29374d1c930de543ca5515f49ec69f950472923425064b30e677b1a3ff04b9b SHA512 45eb984222177a2d63402378db9641d1abebcd7c1a1207687330e71c6f0717278bd3a15e35c988c4846f19ae0eaf1c88cdaf0b74a9f78a35f6826b396420a101
DIST Apache-Test-1.42.tar.gz 153621 BLAKE2B 570c61e4b5f17c97376ba9f4ab3cde0b14df367f06b665e31dba9c6675972ad4d1bebe46b08416b0f4749d723a6b909430c9bdd1e5d3b1c6b21d209635f1236a SHA512 ecd78dde1b0db562d591990bcd50fe880d724dce9bfb20dceea3a51b81abd89d40889857e5e7714b586a093ad6f101dfd79c6aa33d63c906c41c532305b6584c
-EBUILD Apache-Test-1.420.0.ebuild 2893 BLAKE2B a204365692854f363013b5e37d3f4503cae3f3e2416b3bc6184d1b29e5b4d15820bf1064a9aae3c5f5ede09d7e0e6f97222f5338646e2e274e5afdfcac61aac8 SHA512 74a69d8ba9ec76cd333affd684d8627bc61bf0ca725d289525d4244907af1411243dc9d9a428a2672a8cc71f63ce2905305bb39019d6474fe122cd335380e124
+DIST Apache-Test-1.43.tar.gz 153745 BLAKE2B 10988b293d2e4a890451971c98c3c59b262683c65974475e97b5db76bf019f276a264a53cd68fd1bc94fd21e3e6da3d0ad55f01d2b9bf3f9791db572987943dc SHA512 910001c1ca01536ec6f364d9fedf2a9a3a38ebbbbab4ec7d43829e1066317168727a50712c5474ae4bcbde53a1eec6f20f052d74c39a63c4f3f5b3202c48c64a
+EBUILD Apache-Test-1.420.0-r1.ebuild 2378 BLAKE2B 8798268b009bc70db2b9c7ec683514691cced0b6d93f92b4e2da413074742c189a87294d2db037c4a849ec63d0bac5432d1fb66c56fd19335062fd2bb4ec47a4 SHA512 a2baf1dfaaee2ee0bff2540530a5cac787785875b256a0d12ca5822d5086d93a4ae9f83f9c9e3d1dcd35cb9d51e3d050ff149169de7ba2c55630fd267899e87c
+EBUILD Apache-Test-1.430.0.ebuild 2383 BLAKE2B 9591f7dba2e3643e62fee5f3a7b71d07e02a52226ee53426cffd11bed6f8a9dedcafbf6e25905e1bb62a935ccf8758bdddcf8110c662911a7192ea88958f5ec1 SHA512 decf0a5aa3c9cd25321df98aa9fde137d38b90e30ae2d2ef6e46d0a71832715b027f0e7861e1688cd09269407f5f346a5f293a6e0e4a3e70d1cc6cdda0832e3d
MISC metadata.xml 2859 BLAKE2B c61ecfbe2e9cfd8817108b87463a78fa09d89bbe2eec3758f47d32500c76475678ca16c3273cd2b7cd515541d8e344f885e6c9806a3d3d41289c47a79bcbf399 SHA512 a9339164478ccb3d53a6aa1b2e6d036c50b2b7bf50eed3ea6057fad9a4f787b12ec9b4eaf93b741aac6be91d3b1fdcb300b44388a04d6edca06e76d1fb13e047