summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-06 02:09:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-06 02:09:04 +0100
commit51f0d16e058c162dbce0f93d871ba45683b0ab3a (patch)
tree8dd3bc53a0d23549a8f210ce4bfdf74b36b9319f /dev-ml
parent35bf81c760d4e362615c32e69329ef61a01281f7 (diff)
gentoo auto-resync : 06:08:2022 - 02:09:04
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/Manifest.gzbin35145 -> 35147 bytes
-rw-r--r--dev-ml/llvm-ocaml/Manifest1
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-16.0.0.9999.ebuild115
3 files changed, 116 insertions, 0 deletions
diff --git a/dev-ml/Manifest.gz b/dev-ml/Manifest.gz
index c8c1a8e8e889..49ca88a17c7b 100644
--- a/dev-ml/Manifest.gz
+++ b/dev-ml/Manifest.gz
Binary files differ
diff --git a/dev-ml/llvm-ocaml/Manifest b/dev-ml/llvm-ocaml/Manifest
index 554f5f9575d1..8ee9732ae3d9 100644
--- a/dev-ml/llvm-ocaml/Manifest
+++ b/dev-ml/llvm-ocaml/Manifest
@@ -4,4 +4,5 @@ DIST llvmorg-13.0.1.tar.gz 147290251 BLAKE2B 2a44b012a672501761d0c27c6b3a315b69b
EBUILD llvm-ocaml-13.0.1.ebuild 2596 BLAKE2B 4125904f29738c9d1df5dda7737d2edb1e68512f66b561d4ab4b24ebaa457da1a13ab830ab911b5016e05cb48696aff0f6cd1753615e33e8b06f5b086deb020f SHA512 7b80a864207d4c0ef50725a5e9e64c6ff0956b4dfd3f6c55f4363f44703a7113205a39a53624e288562b08ca3191bd11cd7615ecb53395e07777ae7161a173c4
EBUILD llvm-ocaml-14.0.6.ebuild 2594 BLAKE2B 60511c8fbe6fb601e25db4cd2241c0539f829c7c13b55cc142348fa2ac7feff500ddaa00929e7c0152f114cc3dd257f20063290d40a725a5cf05fa51c3ef7072 SHA512 a323d719faa75764be7ae4e663beaf806836b8388521c3aec93ea07a2f3e001a130c7881a15137a7199660a3e0e7baf646391817b09921dab693adbe03c2d173
EBUILD llvm-ocaml-15.0.0.9999.ebuild 2578 BLAKE2B 4daf57c17c61d1195d65de9e2dd0f4f7c55b12dbb829349662db0f8fadec64172daa3d9370bc1387391f326f87b2e03de36ed37a12e72b083beb3e05d79cea12 SHA512 07e210df38ff33721074f544263feebe4a37be0d41118d3c93a820c459e735244c5914a8198df6ce347c4367ea9ba670c70bf54e800684d37121470a76dcdb8f
+EBUILD llvm-ocaml-16.0.0.9999.ebuild 2578 BLAKE2B 4daf57c17c61d1195d65de9e2dd0f4f7c55b12dbb829349662db0f8fadec64172daa3d9370bc1387391f326f87b2e03de36ed37a12e72b083beb3e05d79cea12 SHA512 07e210df38ff33721074f544263feebe4a37be0d41118d3c93a820c459e735244c5914a8198df6ce347c4367ea9ba670c70bf54e800684d37121470a76dcdb8f
MISC metadata.xml 299 BLAKE2B 2feead2cd1b35b3a43335ddd7711f8181b52bc63ee7166608914260c67528add5251349063afbef4f8cf0ec09b2cd4c3ffdd90f2c14ed60bb69ebc03888f6333 SHA512 cd745c54ab18d25bdaff18582105072574103a36cfe7c175ef740f266d00e9fc6f44c332904d23b911c939cf5bdf52973b388923099d8dd5dfef3c283b5cb685
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-16.0.0.9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-16.0.0.9999.ebuild
new file mode 100644
index 000000000000..3f682163a64b
--- /dev/null
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-16.0.0.9999.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit cmake llvm llvm.org python-any-r1
+
+DESCRIPTION="OCaml bindings for LLVM"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0/${PV}"
+KEYWORDS=""
+IUSE="debug test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.00.0:0=
+ dev-ml/ocaml-ctypes:=
+ ~sys-devel/llvm-${PV}:=[debug?]
+ !sys-devel/llvm[ocaml(-)]
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-lang/perl
+ dev-ml/findlib
+ >=dev-util/cmake-3.16
+"
+
+LLVM_COMPONENTS=( llvm cmake third-party )
+LLVM_USE_TARGETS=llvm
+llvm.org_set_globals
+
+pkg_setup() {
+ LLVM_MAX_SLOT=${PV%%.*} llvm_pkg_setup
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local libdir=$(get_libdir)
+ local mycmakeargs=(
+ -DLLVM_LIBDIR_SUFFIX=${libdir#lib}
+
+ -DBUILD_SHARED_LIBS=OFF
+ -DLLVM_BUILD_LLVM_DYLIB=ON
+ -DLLVM_LINK_LLVM_DYLIB=ON
+ -DLLVM_OCAML_OUT_OF_TREE=ON
+
+ # cheap hack: LLVM combines both anyway, and the only difference
+ # is that the former list is explicitly verified at cmake time
+ -DLLVM_TARGETS_TO_BUILD=""
+ -DLLVM_EXPERIMENTAL_TARGETS_TO_BUILD="${LLVM_TARGETS// /;}"
+ -DLLVM_BUILD_TESTS=$(usex test)
+
+ # disable various irrelevant deps and settings
+ -DLLVM_ENABLE_FFI=OFF
+ -DLLVM_ENABLE_TERMINFO=OFF
+ -DHAVE_HISTEDIT_H=NO
+ -DLLVM_ENABLE_ASSERTIONS=$(usex debug)
+ -DLLVM_ENABLE_EH=ON
+ -DLLVM_ENABLE_RTTI=ON
+
+ -DLLVM_HOST_TRIPLE="${CHOST}"
+
+ -DPython3_EXECUTABLE="${PYTHON}"
+
+ # disable go bindings
+ -DGO_EXECUTABLE=GO_EXECUTABLE-NOTFOUND
+
+ # TODO: ocamldoc
+ )
+
+ use test && mycmakeargs+=(
+ -DLLVM_LIT_ARGS="$(get_lit_flags)"
+ )
+
+ # LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
+ # also: custom rules for OCaml do not work for CPPFLAGS
+ use debug || local -x CFLAGS="${CFLAGS} -DNDEBUG"
+ cmake_src_configure
+
+ local llvm_libdir=$(llvm-config --libdir)
+ # an ugly hack; TODO: figure out a way to pass -L to ocaml...
+ cd "${BUILD_DIR}/${libdir}" || die
+ ln -s "${llvm_libdir}"/*.so . || die
+
+ if use test; then
+ local llvm_bindir=$(llvm-config --bindir)
+ # Force using system-installed tools.
+ sed -i -e "/llvm_tools_dir/s@\".*\"@\"${llvm_bindir}\"@" \
+ "${BUILD_DIR}"/test/lit.site.cfg.py || die
+ fi
+}
+
+src_compile() {
+ cmake_build ocaml_all
+}
+
+src_test() {
+ # respect TMPDIR!
+ local -x LIT_PRESERVES_TMP=1
+ cmake_build check-llvm-bindings-ocaml
+}
+
+src_install() {
+ DESTDIR="${D}" \
+ cmake -P "${BUILD_DIR}"/bindings/ocaml/cmake_install.cmake || die
+
+ dodoc bindings/ocaml/README.txt
+}