summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-24 10:45:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-24 10:45:40 +0000
commit1804d2ae908b26fe4e3d3a38646c7d6ffa733d92 (patch)
tree6f5cdff53cb2fde48a01817379124dc476b3742d /dev-ml
parent2fa0c8dbba3b2455531e5616eed64f2fe66cb58b (diff)
gentoo auto-resync : 24:01:2024 - 10:45:40
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/Manifest.gzbin38308 -> 38306 bytes
-rw-r--r--dev-ml/llvm-ocaml/Manifest1
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-19.0.0.9999.ebuild110
-rw-r--r--dev-ml/ppx_blob/Manifest2
-rw-r--r--dev-ml/ppx_blob/ppx_blob-0.7.2.ebuild4
-rw-r--r--dev-ml/ppx_import/Manifest2
-rw-r--r--dev-ml/ppx_import/ppx_import-1.10.0.ebuild4
7 files changed, 117 insertions, 6 deletions
diff --git a/dev-ml/Manifest.gz b/dev-ml/Manifest.gz
index 05ad672afc77..6ac88cbeb5eb 100644
--- a/dev-ml/Manifest.gz
+++ b/dev-ml/Manifest.gz
Binary files differ
diff --git a/dev-ml/llvm-ocaml/Manifest b/dev-ml/llvm-ocaml/Manifest
index 806924946338..01f7856bd88a 100644
--- a/dev-ml/llvm-ocaml/Manifest
+++ b/dev-ml/llvm-ocaml/Manifest
@@ -14,4 +14,5 @@ EBUILD llvm-ocaml-18.0.0.9999.ebuild 2483 BLAKE2B 6ea355363a7d55022a206144faaa93
EBUILD llvm-ocaml-18.0.0_pre20240106.ebuild 2483 BLAKE2B 6ea355363a7d55022a206144faaa939d1fadea7854c4e7dffda2a17887a75352d843680ca7ade9ffea6cd6d1d99b42d406b1088eb4c14f1ef1a6052ce8da831d SHA512 929ccc4105023cdcf1589047fec4b5e00d1abe7b3f57ea32dd4392e4c161f90cb1dab46abb135f195c108ea4c19867fc7203b31f966dd05af50e35a465ce402a
EBUILD llvm-ocaml-18.0.0_pre20240113.ebuild 2483 BLAKE2B 6ea355363a7d55022a206144faaa939d1fadea7854c4e7dffda2a17887a75352d843680ca7ade9ffea6cd6d1d99b42d406b1088eb4c14f1ef1a6052ce8da831d SHA512 929ccc4105023cdcf1589047fec4b5e00d1abe7b3f57ea32dd4392e4c161f90cb1dab46abb135f195c108ea4c19867fc7203b31f966dd05af50e35a465ce402a
EBUILD llvm-ocaml-18.0.0_pre20240120.ebuild 2483 BLAKE2B 6ea355363a7d55022a206144faaa939d1fadea7854c4e7dffda2a17887a75352d843680ca7ade9ffea6cd6d1d99b42d406b1088eb4c14f1ef1a6052ce8da831d SHA512 929ccc4105023cdcf1589047fec4b5e00d1abe7b3f57ea32dd4392e4c161f90cb1dab46abb135f195c108ea4c19867fc7203b31f966dd05af50e35a465ce402a
+EBUILD llvm-ocaml-19.0.0.9999.ebuild 2483 BLAKE2B 6ea355363a7d55022a206144faaa939d1fadea7854c4e7dffda2a17887a75352d843680ca7ade9ffea6cd6d1d99b42d406b1088eb4c14f1ef1a6052ce8da831d SHA512 929ccc4105023cdcf1589047fec4b5e00d1abe7b3f57ea32dd4392e4c161f90cb1dab46abb135f195c108ea4c19867fc7203b31f966dd05af50e35a465ce402a
MISC metadata.xml 299 BLAKE2B 2feead2cd1b35b3a43335ddd7711f8181b52bc63ee7166608914260c67528add5251349063afbef4f8cf0ec09b2cd4c3ffdd90f2c14ed60bb69ebc03888f6333 SHA512 cd745c54ab18d25bdaff18582105072574103a36cfe7c175ef740f266d00e9fc6f44c332904d23b911c939cf5bdf52973b388923099d8dd5dfef3c283b5cb685
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-19.0.0.9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-19.0.0.9999.ebuild
new file mode 100644
index 000000000000..8c4bee7af2e9
--- /dev/null
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-19.0.0.9999.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit cmake llvm llvm.org python-any-r1
+
+DESCRIPTION="OCaml bindings for LLVM"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0/${PV}"
+IUSE="+debug test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.00.0:0=
+ dev-ml/ocaml-ctypes:=
+ ~sys-devel/llvm-${PV}:=[debug?]
+ !sys-devel/llvm[ocaml(-)]
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-lang/perl
+ dev-ml/findlib
+"
+
+LLVM_COMPONENTS=( llvm cmake third-party )
+LLVM_USE_TARGETS=llvm
+llvm.org_set_globals
+
+pkg_setup() {
+ LLVM_MAX_SLOT=${LLVM_MAJOR} llvm_pkg_setup
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local libdir=$(get_libdir)
+ local mycmakeargs=(
+ -DLLVM_LIBDIR_SUFFIX=${libdir#lib}
+
+ -DBUILD_SHARED_LIBS=OFF
+ -DLLVM_BUILD_LLVM_DYLIB=ON
+ -DLLVM_LINK_LLVM_DYLIB=ON
+ -DLLVM_OCAML_OUT_OF_TREE=ON
+
+ # cheap hack: LLVM combines both anyway, and the only difference
+ # is that the former list is explicitly verified at cmake time
+ -DLLVM_TARGETS_TO_BUILD=""
+ -DLLVM_EXPERIMENTAL_TARGETS_TO_BUILD="${LLVM_TARGETS// /;}"
+ -DLLVM_BUILD_TESTS=$(usex test)
+
+ # disable various irrelevant deps and settings
+ -DLLVM_ENABLE_FFI=OFF
+ -DLLVM_ENABLE_TERMINFO=OFF
+ -DHAVE_HISTEDIT_H=NO
+ -DLLVM_ENABLE_ASSERTIONS=$(usex debug)
+ -DLLVM_ENABLE_EH=ON
+ -DLLVM_ENABLE_RTTI=ON
+
+ -DLLVM_HOST_TRIPLE="${CHOST}"
+
+ -DPython3_EXECUTABLE="${PYTHON}"
+
+ # TODO: ocamldoc
+ )
+
+ use test && mycmakeargs+=(
+ -DLLVM_LIT_ARGS="$(get_lit_flags)"
+ )
+
+ # LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
+ # also: custom rules for OCaml do not work for CPPFLAGS
+ use debug || local -x CFLAGS="${CFLAGS} -DNDEBUG"
+ cmake_src_configure
+
+ local llvm_libdir=$(llvm-config --libdir)
+ # an ugly hack; TODO: figure out a way to pass -L to ocaml...
+ cd "${BUILD_DIR}/${libdir}" || die
+ ln -s "${llvm_libdir}"/*.so . || die
+
+ if use test; then
+ local llvm_bindir=$(llvm-config --bindir)
+ # Force using system-installed tools.
+ sed -i -e "/llvm_tools_dir/s@\".*\"@\"${llvm_bindir}\"@" \
+ "${BUILD_DIR}"/test/lit.site.cfg.py || die
+ fi
+}
+
+src_compile() {
+ cmake_build ocaml_all
+}
+
+src_test() {
+ # respect TMPDIR!
+ local -x LIT_PRESERVES_TMP=1
+ cmake_build check-llvm-bindings-ocaml
+}
+
+src_install() {
+ DESTDIR="${D}" \
+ cmake -P "${BUILD_DIR}"/bindings/ocaml/cmake_install.cmake || die
+
+ dodoc bindings/ocaml/README.txt
+}
diff --git a/dev-ml/ppx_blob/Manifest b/dev-ml/ppx_blob/Manifest
index 424402ee27b7..7d577872d820 100644
--- a/dev-ml/ppx_blob/Manifest
+++ b/dev-ml/ppx_blob/Manifest
@@ -1,3 +1,3 @@
DIST ppx_blob-0.7.2.tbz 3155 BLAKE2B 86262f4ef91dde30bbfc466dd0404c0f4825156097d0b019b180332e8f7d91630660f568193f8e8e184d3db07ec9dbc007e888f8dcb6874e2c04a077e8477a16 SHA512 d1701f640ce3dda2e2f0dce7d3f4a6b33ddfdaf793a9beab73e4f9ac93b2912adb7bb3b7fd1800bab258302aef0f0cdefb1e20ee62e6d882b25f0a64eae390a3
-EBUILD ppx_blob-0.7.2.ebuild 500 BLAKE2B ec3063c7d9ce56768612e4db28e635a8e03061bf52aacd6eec70f47d10ec40d43be5f0766ad5595cdbf461d7461750ef9b7110761bd77cf699da03a5b2266501 SHA512 20e9127e599850066890e3ab49b52827e3e01cad8e82fe09d5164d930d69bed4cffcfcfd5e7bd4fdf63e600f1d6cb613750d07e974ca12f67e5a0e7aede82062
+EBUILD ppx_blob-0.7.2.ebuild 504 BLAKE2B 9703902ca7a5304db0147665550ff03a4dd2eab5c89120f4656896cbc34c573cfc945a8a4c995c681fab0a911cf9afec89333af18b96df58639bdea276077099 SHA512 c8c100b80ad9b48a184dd980830fb5d54d8a6d9439450e6e0143aceae375b52148d52bf5a46268fc855b25aa5d7046e2435cec91ac43bcb81b43e4f1a757b7a9
MISC metadata.xml 321 BLAKE2B 05fe6ad30e119812c67c94ed39deb4dabfc1206e414227006a59121c8c38a0bb739ed9204244dfb02a1f22a1f2d3e36990e959c646aa72338f00ba15f85af204 SHA512 afc30ca83d6c8c2ea0cc57687217d4a55ec6d3aff689bfd5e10c8d5c8d905d3ae799f3e46a2f1bd1e2a4de897c97d8cbe59aa8e94801eb80bf4753fd48d5a374
diff --git a/dev-ml/ppx_blob/ppx_blob-0.7.2.ebuild b/dev-ml/ppx_blob/ppx_blob-0.7.2.ebuild
index 44f72a5c6423..e26ecbfa3c55 100644
--- a/dev-ml/ppx_blob/ppx_blob-0.7.2.ebuild
+++ b/dev-ml/ppx_blob/ppx_blob-0.7.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2023 Gentoo Authors
+# Copyright 2023-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/johnwhitington/${PN}/releases/download/${PV}/${P}.tb
LICENSE="Unlicense"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 ~x86"
IUSE="+ocamlopt test"
RESTRICT="!test? ( test )"
diff --git a/dev-ml/ppx_import/Manifest b/dev-ml/ppx_import/Manifest
index 8eaa2d110c9c..a001cd27ad30 100644
--- a/dev-ml/ppx_import/Manifest
+++ b/dev-ml/ppx_import/Manifest
@@ -1,6 +1,6 @@
AUX ppx_import-dune-ounit2.patch 282 BLAKE2B fa927ebd180a00201f234589ede38afce69817507d731aa1c849ddd3c42fd5beb7aaf67e6b57902800311556f0cb9c0436c81bd718a4b5c12fbe4a1aefec903f SHA512 7e62dc441cfed1f2a10ef9f539f35caeef0faedc1e752eec23e8a3c9248ae607ee77600d270bcb9c9be8244ce7b8f3991c7cbff9f82522f2472f9aed514bb861
DIST ppx_import-1.10.0.tar.gz 13927 BLAKE2B d036b730dd9c7b5be9fcbf175103ec6f1e2a14111575135a9cfaf935b936165418b34a4b0a37e0d112b7fbc1315526ce21a9db5bebbd99e1898c4a3c245dcf94 SHA512 7d4aeab6512014b5a16fdcc4d26ac29cc22223e18c7ab26e26f9fdd5bcd625c22aa9ff2e6c2106f45408316eaaf755437979961d97139da5973026038c210935
DIST ppx_import-1.9.1.tar.gz 13820 BLAKE2B 295796041ecad89c95bd6a6fe14a9d9bb969f7d984388cca5181c31b8358affeb92a4d200bb9e11449a0216995a8477b809acf251b049e8331eea9e6bb918cb7 SHA512 37bd54bc477b91a3aa4b2433a9817c6d939f1e4a1d950b83b05964d22540296582cec6513a0959fd036f738dbd6ef9df13430183b8bdaa9425c7640a5fddf4b3
-EBUILD ppx_import-1.10.0.ebuild 635 BLAKE2B 7f221fe5fa6070acd20c7f9ccbd37051948fb715abda3387b2cf4b0339b93e62d56e5c4d8625ccdb51a224c335ea955dd1a8dd375cc2bc81e47eb6fedcd5e176 SHA512 4fc24c0faec3360aff924b6b2d0bafa3b8f3a95287c82278e4eb146e8d9cb5119ece58e4f22afaeb9192af96940410d837b64a13cbf3ffea543278bbfb6fea0b
+EBUILD ppx_import-1.10.0.ebuild 634 BLAKE2B 516a8884fddf0103e77547e91bee890a6970a42f300769cea2038d8729160e7b38de5882afd0bb26f2b79df15dcebd8231bab21ff1defeb58aebc651cc3858cf SHA512 455cd4f489bb6acb5ef99cbbdd19dbf9e4c71f5eee63e2a88ef7b6da55dec6e913da744f4d17a571faea850f942caad2ecd9907c6cfab486133c606cedf58e0c
EBUILD ppx_import-1.9.1-r1.ebuild 659 BLAKE2B 40c085f823b4fed4710d65e616526ae47c0a0b625a0ba8770a6c470865ff8b2f65f5ba672365524ed8542715588b17ed40c2afe51e9e5153e9bbf20e29a08662 SHA512 ed0f015b618b1b341ca0d75d5b6b5ac39f2706e7c15bedbbccbbc6dc7eebc1e36a96a7efc6d066516b61dcb5dd52e553a67e277e0d0d75f146b66106360c47aa
MISC metadata.xml 477 BLAKE2B 81cb703335066a9351b72b455943e55bf3f00d0ad3c3d096aed78f1ce32fb55abd7c125b660fb6f10ff106bd90c1b7e75a2a2826cafe0c5b2e7aae032fd51a0f SHA512 b1f653123da2a260e4b426d459f3b2578c9f24d8c4e387560b6a4dba9f5ffeee8ebff8e5561d343e734b87aee0734d86dad27dc4062d4519f398a3a306ab2dfe
diff --git a/dev-ml/ppx_import/ppx_import-1.10.0.ebuild b/dev-ml/ppx_import/ppx_import-1.10.0.ebuild
index 7e7bd09535f8..0365cdee4c69 100644
--- a/dev-ml/ppx_import/ppx_import-1.10.0.ebuild
+++ b/dev-ml/ppx_import/ppx_import-1.10.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/ocaml-ppx/${PN}/archive/${PV}.tar.gz
LICENSE="MIT"
SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 ~x86"
IUSE="+ocamlopt test"
RESTRICT="!test? ( test )"