summaryrefslogtreecommitdiff
path: root/dev-ml/zed
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-ml/zed
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-ml/zed')
-rw-r--r--dev-ml/zed/Manifest3
-rw-r--r--dev-ml/zed/metadata.xml22
-rw-r--r--dev-ml/zed/zed-3.1.0.ebuild22
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-ml/zed/Manifest b/dev-ml/zed/Manifest
new file mode 100644
index 000000000000..7f13764fe6c3
--- /dev/null
+++ b/dev-ml/zed/Manifest
@@ -0,0 +1,3 @@
+DIST zed-3.1.0.tar.gz 45535 BLAKE2B 8c8898f01add91807fa282baae1c5ee34e77c5234e87e4c79c17a9f55756d3b4c2af5f0b01deb9414a657f63ea6cf6db44af7249adb0f2b147e923b4112a7dd7 SHA512 d4457af15f970adb7b1ed543017e590fa0ecc47171d6dd520a1397f21ce0219caa30a9db7bedb76c0602d4f6d0f0684012cc33feafe18b848d3261a460dea10a
+EBUILD zed-3.1.0.ebuild 481 BLAKE2B 601461c875758a110f37dbae328bbd1d60bd83aa3716c367bb5cfb293b41f643f684c1ad2d6575a550986befca0c77aa7e1de33b4ff7cf843bb2507ced796588 SHA512 50b8d34ecfab53c921fc4c03afade28de347d77adc074c6cf6de757894cb7f9aeb21b7123b20904dcfda4fc744bdf190bdbfcecdc11b8ed7a494125f7101f1fa
+MISC metadata.xml 953 BLAKE2B b42ea3dc0d87de0ba997cbc0a6247dfd420abdd4d2b391a1b5c67c7e694e21039cd46dd2d16e9ab92446b48d8162bc6c14d270d95ae825cab1c2f9b98d0d288a SHA512 6605ba134ef795ff99bac001071fd239a91f0e170c3343fd77a42d7e9850665820aba5770e328a90d653c2bef6df53e804a5a1a1564fc530c9e705fe4d16b4ab
diff --git a/dev-ml/zed/metadata.xml b/dev-ml/zed/metadata.xml
new file mode 100644
index 000000000000..b2be3f06ce46
--- /dev/null
+++ b/dev-ml/zed/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <longdescription>
+ Zed is an abstract engine for text edition. It can be used to write text
+ editors, edition widgets, readlines, ... Zed uses Camomile to fully
+ support the Unicode specification, and implements an UTF-8 encoded string
+ type with validation, and a rope datastructure to achieve efficient
+ operations on large Unicode buffers. Zed also features a regular expression
+ search on ropes. To support efficient text edition capabilities,
+ Zed provides macro recording and cursor management facilities.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/ocaml-community/zed/issues/</bugs-to>
+ <remote-id type="github">ocaml-community/zed</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/zed/zed-3.1.0.ebuild b/dev-ml/zed/zed-3.1.0.ebuild
new file mode 100644
index 000000000000..64634262c7c0
--- /dev/null
+++ b/dev-ml/zed/zed-3.1.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Abstract engine for text edition in OCaml"
+HOMEPAGE="https://github.com/ocaml-community/zed"
+SRC_URI="https://github.com/ocaml-community/zed/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-ml/camomile:=
+ dev-ml/charinfo_width:=
+ dev-ml/react:=
+"
+DEPEND="${RDEPEND}"