summaryrefslogtreecommitdiff
path: root/dev-ml/yojson
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/yojson
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/yojson')
-rw-r--r--dev-ml/yojson/Manifest3
-rw-r--r--dev-ml/yojson/metadata.xml11
-rw-r--r--dev-ml/yojson/yojson-1.4.0.ebuild33
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-ml/yojson/Manifest b/dev-ml/yojson/Manifest
new file mode 100644
index 000000000000..21e8d14c0702
--- /dev/null
+++ b/dev-ml/yojson/Manifest
@@ -0,0 +1,3 @@
+DIST yojson-1.4.0.tar.gz 26197 BLAKE2B c7d1a9d47f448995b31cd7631f64dec29e65b1f141854092bfe186a58c28b96c5c7f246f7e4ab4563dfcd84776904d4af77bbcbdc4e149229fbde339bd92df9f SHA512 dc019ecf0387299282c3df9a548456d2529993241911a83acb14f2361ed14886e5ebebe415773b6bc718cb0b12a25529184f3b5b62c71b42960fbd62e1c63bf6
+EBUILD yojson-1.4.0.ebuild 717 BLAKE2B 032af1cea5c51896945231bef8f53f5be2b79401ea62916615774be324f1069fb35c6c2290f40e616a32a994de12e90573a3e43b3f2e2510ad3a481bf4571825 SHA512 fab7a044839cd7cd13b7537ff3000c4a027ff69c1bb29e96f43e361a06941a8792df3018be945792cafc38b66bd2d955ff2e9b3214858f20c3e9e6d0d1518df7
+MISC metadata.xml 336 BLAKE2B cfb2743ed9621a08d35363acb760a838a06fe02cdcfface33fc399994ab0eb5569a30cc65e9dadc48fe3ac78c9ef01a07777174ee4ea631236650bc5a06be937 SHA512 414975df19a8bb9f75ace586c62505afe6d560d7303c88eb8823d61292b0ae87ab7f6fd2548dee1d08f682dfd31894b7cc8e328d5d68865d643b16d94a05c782
diff --git a/dev-ml/yojson/metadata.xml b/dev-ml/yojson/metadata.xml
new file mode 100644
index 000000000000..81b2fc96c145
--- /dev/null
+++ b/dev-ml/yojson/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mjambon/yojson</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/yojson/yojson-1.4.0.ebuild b/dev-ml/yojson/yojson-1.4.0.ebuild
new file mode 100644
index 000000000000..e3b9f39c5175
--- /dev/null
+++ b/dev-ml/yojson/yojson-1.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib opam
+
+DESCRIPTION="JSON parsing and pretty-printing library for OCaml"
+HOMEPAGE="http://mjambon.com/yojson.html https://github.com/mjambon/yojson"
+SRC_URI="https://github.com/mjambon/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-3.11:=[ocamlopt]
+ dev-ml/easy-format:=[ocamlopt]
+ >=dev-ml/biniou-1.2:=[ocamlopt]
+"
+DEPEND="${RDEPEND}
+ dev-ml/cppo
+ dev-ml/jbuilder
+"
+
+src_install() {
+ opam_src_install
+
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}