summaryrefslogtreecommitdiff
path: root/dev-ml/yojson
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-ml/yojson
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-ml/yojson')
-rw-r--r--dev-ml/yojson/Manifest2
-rw-r--r--dev-ml/yojson/yojson-2.0.0.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-ml/yojson/Manifest b/dev-ml/yojson/Manifest
index 65ad53972348..b2e3d05f2ce9 100644
--- a/dev-ml/yojson/Manifest
+++ b/dev-ml/yojson/Manifest
@@ -1,3 +1,5 @@
DIST yojson-1.7.0.tar.gz 29704 BLAKE2B edbd7f66d69a85880fc8ee9bb25a993744a310887024f7af63665ba8f5067f1b9383ec4d6dd5f4ca3376d698665a8f605c078f7597ddd4e71857c1a20143c2e5 SHA512 25eedb64e4bf7c7e8d5a5a115812cd502540afbdeb7c947da3a14e5968aa0a7db8ab402425662571d8935b9cd6a19796ce81dd80a65dc614f156626c60e7036e
+DIST yojson-2.0.0.tar.gz 44446 BLAKE2B 3b221a016ba418cc6a413921f0d7f2bc239b9a84953bbe9bec2601b159442f3e8bebdf48447367660fec3b3929ea0c08453778e491ce17f9044f505e49d587a6 SHA512 9196e117bb712b970351d12a8d7eae345eef2c92e70e627b58bb95ee49cd58e8a51e6eb5746e2468c15133d53a448ccd229a0568227de0cc8d2eed8b1985609b
EBUILD yojson-1.7.0.ebuild 768 BLAKE2B d7fc71d5d6c18f70f172fa3d3bf39e16d9b206d17ebff4bda65a9a1779a2b32e454e6912d2aa62db5b8bb29b263bab32503c3ded92526951cad7b9bfa732675b SHA512 6ff1bd5e9122cb8e312b29376efa45bd052900b7639a747674a0bc823644cfdd350e82fdf80956b37d73ab1add4975c59ce8943844a52642d6471fb8bf63640e
+EBUILD yojson-2.0.0.ebuild 823 BLAKE2B 4ab5d484807cfaf1cc2557066815c695ff338762396e74d6e7bfd861624279ff61c3fa96efd3e2847ef4527380916ae2b9bf4c7f3a7fdd435553f924abb048d1 SHA512 82fbfca09cfe00bea2defca92e4af05ac24f7ba1648b7f8b7ab8ef9671a6b3bd92385d699b15deeba2908d14a2d740258196757868fe0be60868dfd9a89da120
MISC metadata.xml 529 BLAKE2B 4cfc5392ca4b4402f01251818c776c63d607c2e1b8d216930db594ffe2e1146ac52f9492823e5ef97ba7b6f89b2ee8eaf367e785120ca5fcabdb36549ffb6ebd SHA512 7c415ac7330d8d3397911ddd213da9a6cd5dfe76fa2530ab22cbd70cd8f411fbfdb9d40aa8ca66dc202227799fe0b8ff81c81e57815f5e206c7f424b6218baf1
diff --git a/dev-ml/yojson/yojson-2.0.0.ebuild b/dev-ml/yojson/yojson-2.0.0.ebuild
new file mode 100644
index 000000000000..a46bbd313048
--- /dev/null
+++ b/dev-ml/yojson/yojson-2.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="JSON parsing and pretty-printing library for OCaml"
+HOMEPAGE="https://github.com/ocaml-community/yojson"
+SRC_URI="https://github.com/ocaml-community/yojson/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="examples +ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02.3:=[ocamlopt=]
+ >=dev-ml/seq-0.2.2:=[ocamlopt=]
+"
+DEPEND="${RDEPEND}"
+BDEPEND=">=dev-ml/cppo-1.6.1
+ test? ( dev-ml/alcotest )"
+
+src_prepare() {
+ default
+ # let's not build this
+ rm bench/dune yojson-bench.opam || die
+}
+
+src_install() {
+ dune_src_install
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}