summaryrefslogtreecommitdiff
path: root/dev-ml/xml-light/files/01_installopt.dpatch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ml/xml-light/files/01_installopt.dpatch
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ml/xml-light/files/01_installopt.dpatch')
-rw-r--r--dev-ml/xml-light/files/01_installopt.dpatch24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ml/xml-light/files/01_installopt.dpatch b/dev-ml/xml-light/files/01_installopt.dpatch
new file mode 100644
index 000000000000..1dfb50c9e271
--- /dev/null
+++ b/dev-ml/xml-light/files/01_installopt.dpatch
@@ -0,0 +1,24 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 01_installopt.dpatch by Sylvain Le Gall <gildor@debian.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: No description.
+
+@DPATCH@
+diff -urNad xml-light-2.2~/Makefile xml-light-2.2/Makefile
+--- xml-light-2.2~/Makefile 2005-10-11 23:26:41.000000000 +0200
++++ xml-light-2.2/Makefile 2005-10-11 23:28:00.000000000 +0200
+@@ -11,8 +11,11 @@
+
+ opt: xml-light.cmxa test_opt.exe
+
+-install: all opt
+- cp xml-light.cmxa xml-light.a xml-light.cma xml.mli xmlParser.mli dtd.mli xml.cmi xmlParser.cmi dtd.cmi xml.cmx dtd.cmx xmlParser.cmx $(INSTALLDIR)
++install: all
++ cp xml-light.cma xml.mli xmlParser.mli dtd.mli xml.cmi xmlParser.cmi dtd.cmi $(INSTALLDIR)
++
++installopt: opt all
++ cp xml-light.a xml-light.cmxa xml.cmx dtd.cmx xmlParser.cmx $(INSTALLDIR)
+
+ doc:
+ mkdir doc