summaryrefslogtreecommitdiff
path: root/dev-ml/uutf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/uutf
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/uutf')
-rw-r--r--dev-ml/uutf/Manifest3
-rw-r--r--dev-ml/uutf/metadata.xml11
-rw-r--r--dev-ml/uutf/uutf-1.0.1.ebuild55
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-ml/uutf/Manifest b/dev-ml/uutf/Manifest
new file mode 100644
index 000000000000..f7afc840a89d
--- /dev/null
+++ b/dev-ml/uutf/Manifest
@@ -0,0 +1,3 @@
+DIST uutf-1.0.1.tbz 22215 BLAKE2B 58cbb8db94024ddaa02c213df4e5321ad33513370c6d1d54ac09f57821df8ac3b330c2659f9aeb0e78dfd15d2f50be714a5a5d6e6d3dcc3f81539c1a6c8c3771 SHA512 35cbee8c82a566f2fe4fcd549936d4c4dc67f5b71bfd3ea97ff25d7cf21cfb77cb5ee313c95ad26a2a61bb84aa48c300bbb79a1a7128c6161e9abe9c390a7d18
+EBUILD uutf-1.0.1.ebuild 1496 BLAKE2B 230477a472389176868c422537a393112f128c6ae19d8af64aa410999778f45dd0fc814932c82905655dea4779d285e0dbd533f569b48cee54065c23490f0242 SHA512 21a2c5fdb0178f9864030a889cb4cbd74f263597f886649de2df49a2aad73ae370cdfc12a22803f0183d8f8a339ebda41dc6e2c21dca5c4fbb4b2450dedeb4a2
+MISC metadata.xml 395 BLAKE2B 48ea75ce67ec045366c9257b636a8d2a90743533cb68cf53e036ded8f090b303ff098b4281fb63f66050ff62f070616732be85340e614ff5fac11a22c3cb9cdc SHA512 51bfb51edc7bf10f014be15fc986acf94b2443d93db4883fb3319b2e56b923cbcc360e6b8980eafaa8f628428fdb52d643d62c992fa7444fba1c9b32e876385a
diff --git a/dev-ml/uutf/metadata.xml b/dev-ml/uutf/metadata.xml
new file mode 100644
index 000000000000..0d64748ace0c
--- /dev/null
+++ b/dev-ml/uutf/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+<email>ml@gentoo.org</email>
+<name>Gentoo ML Project</name>
+</maintainer>
+<use>
+<flag name="utftrip">Builds and install the utftrip executable: Among other things, reads unicode on stdin and rewrites it on stdout.</flag>
+</use>
+</pkgmetadata>
diff --git a/dev-ml/uutf/uutf-1.0.1.ebuild b/dev-ml/uutf/uutf-1.0.1.ebuild
new file mode 100644
index 000000000000..3e6636aa1def
--- /dev/null
+++ b/dev-ml/uutf/uutf-1.0.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit findlib
+
+DESCRIPTION="Non-blocking streaming Unicode codec for OCaml"
+HOMEPAGE="http://erratique.ch/software/uutf"
+SRC_URI="http://erratique.ch/software/uutf/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="doc utftrip +ocamlopt test"
+
+RDEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]
+ dev-ml/uchar:=
+ utftrip? ( dev-ml/cmdliner:= )"
+DEPEND="${RDEPEND}
+ dev-ml/ocamlbuild
+ dev-ml/topkg
+ test? ( dev-ml/cmdliner )"
+
+src_compile() {
+ ocaml pkg/pkg.ml build \
+ --with-cmdliner "$(usex utftrip true false)" \
+ || die
+}
+
+src_test() {
+ if use ocamlopt ; then
+ ocamlbuild -use-ocamlfind tests.otarget || die
+ pushd _build/test || die
+ ./test.native || die
+ #Rebuild to avoid mismatches between installed files, bug #604674
+ popd || die
+ ocaml pkg/pkg.ml build \
+ --with-cmdliner "$(usex utftrip true false)" \
+ || die
+ else
+ ewarn "Sorry, ${PN} tests require native support (ocamlopt)"
+ fi
+}
+
+src_install() {
+ # Can't use opam-installer here as it is an opam dep...
+ findlib_src_preinst
+ local nativelibs=""
+ use ocamlopt && nativelibs="$(echo _build/src/uutf.cm{x,xa,xs} _build/src/uutf.a)"
+ ocamlfind install uutf _build/pkg/META _build/src/uutf.mli _build/src/uutf.cm{a,i} ${nativelibs} || die
+ use utftrip && newbin utftrip.$(usex ocamlopt native byte) utftrip
+ dodoc CHANGES.md README.md
+ use doc && dohtml -r doc/*
+}