summaryrefslogtreecommitdiff
path: root/dev-ml/uutf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
commit814f4cf860e299a046b649eaee5463427984c09c (patch)
tree74c45f097899310e599dad6b8df5b63e0f085bc0 /dev-ml/uutf
parent7f0ccc917c7abe6223784c703d86cd14755691fb (diff)
gentoo resync : 08.07.2021
Diffstat (limited to 'dev-ml/uutf')
-rw-r--r--dev-ml/uutf/Manifest2
-rw-r--r--dev-ml/uutf/uutf-1.0.2.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-ml/uutf/Manifest b/dev-ml/uutf/Manifest
index ddcef2b5e763..b750f058df47 100644
--- a/dev-ml/uutf/Manifest
+++ b/dev-ml/uutf/Manifest
@@ -1,3 +1,5 @@
DIST uutf-1.0.1.tbz 22215 BLAKE2B 58cbb8db94024ddaa02c213df4e5321ad33513370c6d1d54ac09f57821df8ac3b330c2659f9aeb0e78dfd15d2f50be714a5a5d6e6d3dcc3f81539c1a6c8c3771 SHA512 35cbee8c82a566f2fe4fcd549936d4c4dc67f5b71bfd3ea97ff25d7cf21cfb77cb5ee313c95ad26a2a61bb84aa48c300bbb79a1a7128c6161e9abe9c390a7d18
+DIST uutf-1.0.2.tbz 22420 BLAKE2B 8391f6c3cde40db3fa86b9243d8ea8fb52409aa958d1020f302d602bf7c06c44b7d93f7a6a64a1b0964c7bb5856e15178957bba48102dbd36d8efe9581db3787 SHA512 5f2dbe78eaf73a292438d84c7185c839a7ac13cee9616a7b5006990314c6a0d42b212854cc2e89d815d3c45804f94bb40af75ecb60da7092887d8dc21e968bdd
EBUILD uutf-1.0.1.ebuild 1589 BLAKE2B 97df4d6bd39a80eaa5e1cf303b2a7ce5735cf4df7564282b6d0b98b23f6f51063c20f120eda76220aae96c80a95bdb9523bb3494149ea5cb91572b60962b465e SHA512 c56f090492fab0564607595faa7e5765ffd7e13d3bda71e0ed99841bb01183c286b7e7c552e5766626674169bcf88604a6ff9ffa720d21fdd46bd8e38cbc1f65
+EBUILD uutf-1.0.2.ebuild 1595 BLAKE2B a9958781ecb69f2e8e160ee23607ed0b6f3fe9501ec9ab3146e59e30fc475d81992976955d33a78a10f04ee895d3bf0c312dbdba97a50cc3c5c4bca40baa7afd SHA512 f233de55edd0e346bf851a824e4ce31923cf02153a874f46b46dcbf1666a1059d88170c555891e2fc52d57cb304bad6835a77a93423825e105cc8b75172187ed
MISC metadata.xml 390 BLAKE2B c7f6ffb069cf171a47ffaf90b0bbd742d50baa96260e98b21738651722d3006e176f4bc5223932986b2640aa1f091861c7a027f5b4130ed2af77b7ae1e2701bb SHA512 b23f82ba753956db53103340358857cbdee18bc34ee5d5db86d68dc6f04ea419b3f64df7e5fa54ac84e6122eef7236daebda8fbd60aaa7fa59d45714d21aec4a
diff --git a/dev-ml/uutf/uutf-1.0.2.ebuild b/dev-ml/uutf/uutf-1.0.2.ebuild
new file mode 100644
index 000000000000..320c6dea77ec
--- /dev/null
+++ b/dev-ml/uutf/uutf-1.0.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+DESCRIPTION="Non-blocking streaming Unicode codec for OCaml"
+HOMEPAGE="https://erratique.ch/software/uutf"
+SRC_URI="https://erratique.ch/software/uutf/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="doc utftrip +ocamlopt test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="utftrip? ( ocamlopt )"
+
+RDEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]
+ dev-ml/uchar:=
+ utftrip? ( dev-ml/cmdliner:= )"
+DEPEND="${RDEPEND}
+ dev-ml/ocamlbuild
+ dev-ml/topkg
+ test? ( dev-ml/cmdliner )"
+
+src_compile() {
+ ocaml pkg/pkg.ml build \
+ --with-cmdliner "$(usex utftrip true false)" \
+ || die
+}
+
+src_test() {
+ if use ocamlopt ; then
+ ocamlbuild -use-ocamlfind tests.otarget || die
+ pushd _build/test || die
+ ./test.native || die
+ # Rebuild to avoid mismatches between installed files, bug #604674
+ popd || die
+ ocaml pkg/pkg.ml build \
+ --with-cmdliner "$(usex utftrip true false)" \
+ || die
+ else
+ ewarn "Sorry, ${PN} tests require native support (ocamlopt)"
+ fi
+}
+
+src_install() {
+ # Can't use opam-installer here as it is an opam dep...
+ findlib_src_preinst
+ local nativelibs=""
+
+ use ocamlopt && nativelibs="$(echo _build/src/uutf.cm{x,xa,xs} _build/src/uutf.a)"
+ ocamlfind install uutf _build/pkg/META _build/src/uutf.mli _build/src/uutf.cm{a,i} ${nativelibs} || die
+
+ use utftrip && newbin utftrip.$(usex ocamlopt native byte) utftrip
+ dodoc CHANGES.md README.md
+
+ if use doc ; then
+ docinto html
+ dodoc -r doc/*
+ fi
+}