summaryrefslogtreecommitdiff
path: root/dev-ml/uuseg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-13 05:48:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-13 05:48:01 +0000
commit4bc834b03b9438dcfd45780f31a02994c24608ba (patch)
tree1ee84a24bd250533fbdadfa949f438db20ba98aa /dev-ml/uuseg
parent175512fa7c74d0e48a7a1b40a6e456435af0481b (diff)
gentoo auto-resync : 13:01:2023 - 05:48:01
Diffstat (limited to 'dev-ml/uuseg')
-rw-r--r--dev-ml/uuseg/Manifest3
-rw-r--r--dev-ml/uuseg/metadata.xml23
-rw-r--r--dev-ml/uuseg/uuseg-15.0.0.ebuild38
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-ml/uuseg/Manifest b/dev-ml/uuseg/Manifest
new file mode 100644
index 000000000000..fac47c8eb601
--- /dev/null
+++ b/dev-ml/uuseg/Manifest
@@ -0,0 +1,3 @@
+DIST uuseg-15.0.0.tar.gz 25540 BLAKE2B 4ee1512bde79aab4777395d3ccfb8fe76c97ba7e93b722acd7c36acac432a44a9eade512ea45a0204a1d947a60e3d61773de05890d64d7afac4b1965d1493bb3 SHA512 c117868d52ca8f5de3104b0ea25ea011c19cefd53018c4d9bdf900185d04f74c097b7f129b75366a8da905a79dac3cbf8e6c66ff6c20fee1c2e42b9cdd6a9fa6
+EBUILD uuseg-15.0.0.ebuild 716 BLAKE2B f7f9bf91292d206612de4694d5f0d0ad5dcad001f64dc79ec051346745e055f21c05d16b5f02cc64b8061334eb33514d431a0fcd8d8d775ccbbd5a060b1ccfe7 SHA512 060f48421b1d1b746124d5501d6b1684153e6abb446275083a4052a35b988bb521e51c25dfe78a8b8ebdc17c8ccd45452f35853b5729b51af117ad8255ab57a9
+MISC metadata.xml 1002 BLAKE2B 14f5a9298b9d11dd13223511e22eb4125f424236cb53acfbe19030abd6c2578c26d6388dd11724bfb7bf4ebb9b4c9bbdf7e69020fbfbec39d12cff3b5af61d85 SHA512 2263e315de73941247a7926928e648b6c5dc2fac151b9db1dca7dc5d1af3c80c1cb72d5ec601ad262f2166fcb4cf7532ba0ec8a59f6455ced007f6282299f63a
diff --git a/dev-ml/uuseg/metadata.xml b/dev-ml/uuseg/metadata.xml
new file mode 100644
index 000000000000..83ae1c163f95
--- /dev/null
+++ b/dev-ml/uuseg/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <longdescription>
+ Uuseg is an OCaml library for segmenting Unicode text. It implements the
+ locale independent Unicode text segmentation algorithms to detect grapheme
+ cluster, word and sentence boundaries and the Unicode line breaking
+ algorithm to detect line break opportunities. The library is independent
+ from any IO mechanism or Unicode text data structure and it can process
+ text without a complete in-memory representation. Uuseg depends on Uucp and
+ optionally on Uutf for support on OCaml UTF-X encoded strings. It is
+ distributed under the ISC license.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/dbuenzli/uuseg/issues/</bugs-to>
+ <remote-id type="github">dbuenzli/uuseg</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/uuseg/uuseg-15.0.0.ebuild b/dev-ml/uuseg/uuseg-15.0.0.ebuild
new file mode 100644
index 000000000000..d3dd9d062ae2
--- /dev/null
+++ b/dev-ml/uuseg/uuseg-15.0.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit opam
+
+DESCRIPTION="Unicode text segmentation for OCaml"
+HOMEPAGE="https://erratique.ch/software/uuseg/
+ https://github.com/dbuenzli/uuseg/"
+SRC_URI="https://github.com/dbuenzli/uuseg/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ml/cmdliner:=
+ dev-ml/uucp:=
+ dev-ml/uutf:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-ml/ocamlbuild
+ dev-ml/findlib
+ dev-ml/topkg
+"
+
+src_compile() {
+ ocaml pkg/pkg.ml build --tests $(usex test true false) || die
+}
+
+src_test() {
+ ocaml pkg/pkg.ml test || die
+}