summaryrefslogtreecommitdiff
path: root/dev-ml/uunf/uunf-13.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-ml/uunf/uunf-13.0.0.ebuild
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-ml/uunf/uunf-13.0.0.ebuild')
-rw-r--r--dev-ml/uunf/uunf-13.0.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ml/uunf/uunf-13.0.0.ebuild b/dev-ml/uunf/uunf-13.0.0.ebuild
new file mode 100644
index 000000000000..5c1c8bdaf9b8
--- /dev/null
+++ b/dev-ml/uunf/uunf-13.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit opam
+
+DESCRIPTION="Unicode text normalization"
+HOMEPAGE="https://erratique.ch/software/uunf https://github.com/dbuenzli/uunf"
+SRC_URI="https://erratique.ch/software/uunf/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-ml/topkg
+ dev-ml/uutf
+ dev-ml/cmdliner"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-ml/findlib"
+OPAM_FILE=opam
+
+src_compile() {
+ ocaml pkg/pkg.ml build \
+ || die
+}