summaryrefslogtreecommitdiff
path: root/dev-ml/uuidm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /dev-ml/uuidm
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'dev-ml/uuidm')
-rw-r--r--dev-ml/uuidm/Manifest3
-rw-r--r--dev-ml/uuidm/metadata.xml11
-rw-r--r--dev-ml/uuidm/uuidm-0.9.7.ebuild25
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/uuidm/Manifest b/dev-ml/uuidm/Manifest
new file mode 100644
index 000000000000..6560b619c554
--- /dev/null
+++ b/dev-ml/uuidm/Manifest
@@ -0,0 +1,3 @@
+DIST uuidm-0.9.7.tar.gz 9258 BLAKE2B 37867ee562fcf5c44e0f40df53707a5066d74c185037049b4b4034326e1efa93543d518f6c9d5d27e9663f18d824f951d27952c844e1169d951abb7b91caeebb SHA512 7048e467bbd9eefd19ca057caadcc8f634d4eae7642665a84df88f726df3fb849085613d75a485272b0d0e19c9041c560a8c864e780dbed29ff68e3cfa8ba3d4
+EBUILD uuidm-0.9.7.ebuild 527 BLAKE2B ed2b4ece5eb027fc95f31c6f981a17cb5f227ede843c7935b351f6525d6ebcffcdf5809be44575ee7641fc97962c233c523a54abfbe623a79f5b436a9a7ea3e2 SHA512 07835044ce87b7f282243019b40d27e21599a824cf87b55598a0054d6af878b37309fb90fe2ca75acc2b5ecc607e19243ee34530a6a66449a95c4fb2cabef879
+MISC metadata.xml 311 BLAKE2B 75a1f9b63ac21f0a74bc7fafcdd6917c54bb97983c39e56de05c4b07611ce2011f635376453fb8493cf5d29714defabe2d67193ab03f6a8fc5a917700e171cf3 SHA512 87a9ab7d29495118af3ad93e9a231e6f1c204a744c570fa7896a44d7982e737cb96cb6233b0fe4ac6137d34af145323fe0a5d7d86ac44c5037f003a2ae9358f8
diff --git a/dev-ml/uuidm/metadata.xml b/dev-ml/uuidm/metadata.xml
new file mode 100644
index 000000000000..01e057cc5972
--- /dev/null
+++ b/dev-ml/uuidm/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">dbuenzli/uuidm</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/uuidm/uuidm-0.9.7.ebuild b/dev-ml/uuidm/uuidm-0.9.7.ebuild
new file mode 100644
index 000000000000..426070a07538
--- /dev/null
+++ b/dev-ml/uuidm/uuidm-0.9.7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit opam
+
+DESCRIPTION="Universally unique identifiers (UUIDs) for OCaml"
+HOMEPAGE="https://github.com/dbuenzli/uuidm"
+SRC_URI="https://github.com/dbuenzli/uuidm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+BDEPEND="
+ dev-ml/findlib[ocamlopt=]
+ dev-ml/ocamlbuild[ocamlopt=]
+ dev-ml/topkg
+"
+
+src_compile() {
+ ocaml pkg/pkg.ml build || die
+}