summaryrefslogtreecommitdiff
path: root/dev-ml/utop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-14 12:27:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-14 12:27:14 +0100
commitf7adcd4ee556b2c3a420239c13fb74113d791f6a (patch)
tree1cc566bbd03612996262177e95152bdda507cca9 /dev-ml/utop
parent482a48c0e1675b1e92663b8b5222bb7261aa7956 (diff)
gentoo auto-resync : 14:07:2024 - 12:27:13
Diffstat (limited to 'dev-ml/utop')
-rw-r--r--dev-ml/utop/Manifest2
-rw-r--r--dev-ml/utop/utop-2.14.0.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-ml/utop/Manifest b/dev-ml/utop/Manifest
index 9423fffb22ec..8b2aebf6b1a1 100644
--- a/dev-ml/utop/Manifest
+++ b/dev-ml/utop/Manifest
@@ -1,4 +1,6 @@
AUX 50utop-gentoo.el 100 BLAKE2B eb2061a156c26f41f06076905e66212743aca67b3692c14f5347006aeda59f05d973f766fd65c97dfd14ab0dca22cac831076c7809e12d509253483cd0ab8bb4 SHA512 80ef89749dc68e7d339bc6fc63984b56913b3d94c22fa38ab82a6d4e4867ea30e94ce116d25212785d00ce721909fbda3cb3ff9e710e617e241b42f8152b18d2
DIST utop-2.12.1.tar.gz 416596 BLAKE2B a8a31c91fd4f989e3d89bc736caa7b611ba0ccc2de905adcd1cf59fff87770d5a00c2d7a43462940269ae8be2f5980fa5b8d2ec7ba547b937cc1e6a579621f2f SHA512 cc52bdb2a58141e6f7b678c93f69b0aa5ca4c628cb6841e02e6a783191a917bd838c06682d55f4f455a01a7004e43b5193d8574968b8400050b0f7b5a102ca3a
+DIST utop-2.14.0.tar.gz 418609 BLAKE2B 726ff00d6ce13f6bb81b6e1ad82749094f25a6394f6552f2a976f270d182a7b600a9a17a1c692e56fa807332b25638a8cf0c2082c12ef93262ef5409633fba27 SHA512 16c724c0d54cd14d2126060f00e8b86fe3b886cffd7ff306a825d7f9e045b74ffc5830f659ccb151dfaa36c41c2966c26bc2c2e7567f9e1d725b33e9f677d19e
EBUILD utop-2.12.1.ebuild 1068 BLAKE2B e4f9aa5170aa046f5f07737cbca7e5dac2ab916ad41b7483fc3971cfd3430f28f6d304de4f1b496169093b2a279ba189bb07888710c1f6e60c7cdacc5f514a3e SHA512 d63f4757e29f790d84274f890ba7dcfc90e95c322fc1f94ee853c0a6de7a396ce9ab99780f891207bbf8812c45e665263b6aa4884451f5952fd44b96da0bcecf
+EBUILD utop-2.14.0.ebuild 1160 BLAKE2B 6b7f5e689e4248fa1d0ffbce3346d3fd6c8d2fe3b4d1d1b91a8f053fcda7f59814990b098b02c1bc23cdb6c6edd9c3b4eb0e0b1596a8c7313023bbaf77415b88 SHA512 bf9012662cdc4ef92efa8bcda5a69adb60b7669f1ef811ab427102fbfc0edc8ae928a9e39410b3fdafcff4240baf1ae1e5717a97c42c48ba1926c4c759d98ead
MISC metadata.xml 714 BLAKE2B cdcb086ec113872a316e1f98b53802f6faef22a718543527c5cd5d4038ac68a601bb0898532428378ce016e4d018074c043e8dafb4109ac7fcd233cabe1f3c54 SHA512 40468222a996f4b5bebf03ab5d2d7fc639ab00acba23ea98da3a4a7993864946d2327c296806e0106e5d150c90d5286629d9608bc0e04acbd94fc5fd1ba50bf4
diff --git a/dev-ml/utop/utop-2.14.0.ebuild b/dev-ml/utop/utop-2.14.0.ebuild
new file mode 100644
index 000000000000..788125604fb3
--- /dev/null
+++ b/dev-ml/utop/utop-2.14.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune elisp-common
+
+DESCRIPTION="Universal toplevel for OCaml"
+HOMEPAGE="https://github.com/ocaml-community/utop"
+SRC_URI="https://github.com/ocaml-community/utop/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="emacs +ocamlopt"
+
+ELISP_DEPEND="
+ emacs? (
+ >=app-editors/emacs-24:*
+ >=app-emacs/tuareg-mode-2.2.0
+ )
+"
+DEPEND="
+ >=dev-lang/ocaml-4.11
+ dev-ml/lambda-term:=[ocamlopt?]
+ dev-ml/logs:=[ocamlopt?]
+ dev-ml/lwt:=[ocamlopt?]
+ dev-ml/react:=
+ dev-ml/xdg:=[ocamlopt?]
+ dev-ml/zed:=[ocamlopt?]
+"
+RDEPEND="
+ ${DEPEND}
+ ${ELISP_DEPEND}
+"
+BDEPEND="
+ dev-ml/cppo
+ dev-ml/findlib
+ ${ELISP_DEPEND}
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ dune_src_compile
+
+ use emacs &&
+ BYTECOMPFLAGS="-L src/top" elisp-compile src/top/*.el
+}
+
+src_install() {
+ dune_src_install
+
+ if use emacs ; then
+ elisp-install ${PN} src/top/*.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}