summaryrefslogtreecommitdiff
path: root/dev-ml/utop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-ml/utop
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-ml/utop')
-rw-r--r--dev-ml/utop/Manifest5
-rw-r--r--dev-ml/utop/metadata.xml19
-rw-r--r--dev-ml/utop/utop-2.8.0.ebuild27
-rw-r--r--dev-ml/utop/utop-2.9.0.ebuild27
4 files changed, 78 insertions, 0 deletions
diff --git a/dev-ml/utop/Manifest b/dev-ml/utop/Manifest
new file mode 100644
index 000000000000..8cfc76f30e03
--- /dev/null
+++ b/dev-ml/utop/Manifest
@@ -0,0 +1,5 @@
+DIST utop-2.8.0.tar.gz 414059 BLAKE2B f94cc9a2e87d5341b1d7231574b1e0d8b179e600640281529ecfd2ce8827b9145d73030ea1ec59b20430d34155087f6d910c698c75d7566145c9db3a3ecbf872 SHA512 cf323249aa9a747081b3e39e8e8b99b69557082beb244dd0a28d64c6d11e3c03427c22da4fd364e9ae7f5d83d12ca3d2d48b9f4b6697ec704d486f3c23163dba
+DIST utop-2.9.0.tar.gz 414953 BLAKE2B 96fbf38d4a638137b73264bc523b8a81e47ddd609a7987073313f4b1d628e4e84c31f98195105911dd0930b8d27007cf5cc1633771bc6d2e975bd169e1e3ba9c SHA512 dd3f52fb915493cb32b5ee722361e884a481d04ef175d5bdf58f4032b70826c38b2f5279b7c64b78961170a86bc80fbd59f03026fac99bb5da2b46a8f341aa45
+EBUILD utop-2.8.0.ebuild 522 BLAKE2B 60492098157329523c0925fb648af6966a1f73495cd65baff95cec5e7fb13698ab3f81160a89a5be0971a0ead75fdc22e91ba72b1214eafe3032bcd891f12d98 SHA512 ae402dd577415dd451477efa25c8098ed83f502055e8e380cf19e3383b14bc503173f4f49e5c9580d4fc13b8e234b6d98bc02c080c0c8e310e2b3ac1070eaf98
+EBUILD utop-2.9.0.ebuild 522 BLAKE2B 60492098157329523c0925fb648af6966a1f73495cd65baff95cec5e7fb13698ab3f81160a89a5be0971a0ead75fdc22e91ba72b1214eafe3032bcd891f12d98 SHA512 ae402dd577415dd451477efa25c8098ed83f502055e8e380cf19e3383b14bc503173f4f49e5c9580d4fc13b8e234b6d98bc02c080c0c8e310e2b3ac1070eaf98
+MISC metadata.xml 713 BLAKE2B 0d4431b068fd0cddd59703eb1deaac0a09ff987cdf97c551712e4465cd2322de0d615f28346213219effad5618db768ec389c14872ec0beaacf5f335594555e4 SHA512 f3b1cc264cdfb60d77321fcdb4d66c8aa9599e7ccfb78261e4209d5cceb617ddc8a3beec6224c3544ea71debf2efdfa5db9b18bfc990aa7f129ed54e49f46166
diff --git a/dev-ml/utop/metadata.xml b/dev-ml/utop/metadata.xml
new file mode 100644
index 000000000000..575a666b2394
--- /dev/null
+++ b/dev-ml/utop/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <longdescription>
+ utop is an improved toplevel (i.e., Read-Eval-Print Loop or REPL) for
+ OCaml. It can run in a terminal or in Emacs. It supports line edition,
+ history, real-time and context sensitive completion, colors, and more.
+ It integrates with the Tuareg mode in Emacs.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/ocaml-community/utop/issues/</bugs-to>
+ <remote-id type="github">ocaml-community/utop</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/utop/utop-2.8.0.ebuild b/dev-ml/utop/utop-2.8.0.ebuild
new file mode 100644
index 000000000000..d5b493a8c2cf
--- /dev/null
+++ b/dev-ml/utop/utop-2.8.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Universal toplevel for OCaml"
+HOMEPAGE="https://github.com/ocaml-community/utop"
+SRC_URI="https://github.com/ocaml-community/utop/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-ml/camomile:=
+ dev-ml/lambda-term:=
+ dev-ml/lwt:=
+ dev-ml/react:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-ml/cppo
+ dev-ml/findlib
+"
diff --git a/dev-ml/utop/utop-2.9.0.ebuild b/dev-ml/utop/utop-2.9.0.ebuild
new file mode 100644
index 000000000000..d5b493a8c2cf
--- /dev/null
+++ b/dev-ml/utop/utop-2.9.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Universal toplevel for OCaml"
+HOMEPAGE="https://github.com/ocaml-community/utop"
+SRC_URI="https://github.com/ocaml-community/utop/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-ml/camomile:=
+ dev-ml/lambda-term:=
+ dev-ml/lwt:=
+ dev-ml/react:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-ml/cppo
+ dev-ml/findlib
+"