summaryrefslogtreecommitdiff
path: root/dev-ml/utop/utop-2.9.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-25 00:11:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-25 00:11:21 +0100
commit3e837954479e3c2c67afb16e6d997cbd1526c77c (patch)
treec9b8c7298847e53f6ca44fc241fc10994eec7360 /dev-ml/utop/utop-2.9.0-r1.ebuild
parentfd2d39fd67383629dd37da6b317730d47822cbb0 (diff)
gentoo auto-resync : 25:04:2023 - 00:11:21
Diffstat (limited to 'dev-ml/utop/utop-2.9.0-r1.ebuild')
-rw-r--r--dev-ml/utop/utop-2.9.0-r1.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/dev-ml/utop/utop-2.9.0-r1.ebuild b/dev-ml/utop/utop-2.9.0-r1.ebuild
deleted file mode 100644
index cd05e5fc7a0c..000000000000
--- a/dev-ml/utop/utop-2.9.0-r1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit dune elisp-common
-
-DESCRIPTION="Universal toplevel for OCaml"
-HOMEPAGE="https://github.com/ocaml-community/utop"
-SRC_URI="https://github.com/ocaml-community/utop/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="emacs +ocamlopt"
-
-ELISP_DEPEND="
- emacs? (
- >=app-editors/emacs-24:*
- >=app-emacs/tuareg-mode-2.2.0
- )
-"
-DEPEND="
- dev-ml/camomile:=
- dev-ml/lambda-term:=
- dev-ml/lwt:=
- dev-ml/react:=
-"
-RDEPEND="
- ${DEPEND}
- ${ELISP_DEPEND}
-"
-BDEPEND="
- dev-ml/cppo
- dev-ml/findlib
- ${ELISP_DEPEND}
-"
-
-SITEFILE="50${PN}-gentoo.el"
-
-src_compile() {
- dune_src_compile
-
- use emacs &&
- BYTECOMPFLAGS="-L src/top" elisp-compile src/top/*.el
-}
-
-src_install() {
- dune_src_install
-
- if use emacs ; then
- elisp-install ${PN} src/top/*.el{,c}
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}