summaryrefslogtreecommitdiff
path: root/dev-ml/uopt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-16 00:09:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-16 00:09:44 +0100
commit0a3feeaba4dbc58966dccdbbfcd7fb14deef0831 (patch)
treed48a200142b883af377722ab54ec0c1d8c19912f /dev-ml/uopt
parent6a7029e0f7370d4d5dfe9e31cc2719a870482392 (diff)
gentoo auto-resync : 16:06:2024 - 00:09:44
Diffstat (limited to 'dev-ml/uopt')
-rw-r--r--dev-ml/uopt/Manifest3
-rw-r--r--dev-ml/uopt/metadata.xml11
-rw-r--r--dev-ml/uopt/uopt-0.17.0.ebuild23
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/uopt/Manifest b/dev-ml/uopt/Manifest
new file mode 100644
index 000000000000..eec8660ed99f
--- /dev/null
+++ b/dev-ml/uopt/Manifest
@@ -0,0 +1,3 @@
+DIST uopt-0.17.0.tar.gz 5880 BLAKE2B d1e18fafad21ad98d7d5a7f2c39121c6b097a3f295616a6ebc33c438452f2c35e1d6040a5bf893d3d4e889e3783283f36c7571b3b676f5dd81517b2a2ede49a3 SHA512 ccee93d326f3ceb9d844b3470f27d7f1eb7fd20818be564557293373c544ac2dc6d1db48f1972f5525a11c7976711eb903dd4be0afd17c9b0118dc62be193811
+EBUILD uopt-0.17.0.ebuild 566 BLAKE2B 87601d4010d60bcb5f284c3a2685de7a33b90298dd01eb281ed6f288c0e56b68f12e3cd084426334564601b8b85bba7011f00b1bdc517f90d1c3603b95642631 SHA512 9739eec6dab6726b9b4edda821099915aeef8852f12e56d609468504217a117b471cc11ffe35d6382bdea9730bb32af5c7401e07a6d599c4055a39934e246945
+MISC metadata.xml 313 BLAKE2B 4f3f7a98fa3bb84b3cfecba71566aea754445af3f33fb8b74ce6dadea072037dc92b5adcc1e0c2791e1ce1f65edad77f61e9dca1f36937bfd247d80f5e99acb1 SHA512 1fc021f9531a26a6d19b3850a751c6107943293265d7c4a0da4de9ca788a80acdb809693009e2299c3b64ba52c42aa82d5704f77f7b5a1921ac3fadb240f2ebe
diff --git a/dev-ml/uopt/metadata.xml b/dev-ml/uopt/metadata.xml
new file mode 100644
index 000000000000..0357c74bd81b
--- /dev/null
+++ b/dev-ml/uopt/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">janestreet/uopt</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/uopt/uopt-0.17.0.ebuild b/dev-ml/uopt/uopt-0.17.0.ebuild
new file mode 100644
index 000000000000..5788d919c172
--- /dev/null
+++ b/dev-ml/uopt/uopt-0.17.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="An [option]-like type that incurs no allocation"
+HOMEPAGE="https://github.com/janestreet/uopt"
+SRC_URI="https://github.com/janestreet/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-5
+ dev-ml/base:${SLOT}[ocamlopt?]
+ dev-ml/ppx_jane:${SLOT}[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND=">=dev-ml/dune-3.11"