summaryrefslogtreecommitdiff
path: root/dev-ml/uchar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/uchar
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/uchar')
-rw-r--r--dev-ml/uchar/Manifest3
-rw-r--r--dev-ml/uchar/metadata.xml11
-rw-r--r--dev-ml/uchar/uchar-0.0.2.ebuild41
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-ml/uchar/Manifest b/dev-ml/uchar/Manifest
new file mode 100644
index 000000000000..248edfdc5808
--- /dev/null
+++ b/dev-ml/uchar/Manifest
@@ -0,0 +1,3 @@
+DIST uchar-0.0.2.tar.gz 21815 BLAKE2B aede9d42ac2d9ccaa7af2f40799916f30cef0d6e292b7909b5131b5d28c979362b7624a88cec8ba2e7bed1dcada60d8e512ed70d2a02dafcf4ad701c60f6faa6 SHA512 487a9706cf9dfc9b9c94442a51766cc211687d6ebcb4dd3c94d09cb1ed6d7fd61e966e91a4121fe2d1681b2fd6bfee9079d3bccccdb6d65ba2111524ab5dd1bc
+EBUILD uchar-0.0.2.ebuild 1129 BLAKE2B 712b837d322eabff7855bf7aa4a900db5cc5d5d49ba21ea36498562ab9a17ceb55038a58bfa647ecfb4c23e89516f180f84bee245a6877c800901052e4ad6711 SHA512 ba7c13bc9c2262b11802165b827e6e7b7f01f269101b56c1325ab776fdc2c58e7731664ce7395add3809530cf751e0989c6354a2b7c90a919053160b60a0a344
+MISC metadata.xml 323 BLAKE2B 6e76684e3b7cb869df836ef5abbe8de6db1c278e1638d5f0c8e6915d78c904ea112efffaeb80a68440bc9f4444064ebc83c1cf748ae765521e9518e8b7ccc616 SHA512 44830fe5dae4de1d5fcc0e9f5ca8373aa7fcda8a2a1d12161128d1ae0f5012d70e362f2b586c6b6e73492ec943deb36e591f4cc1fd9a56f43d6f35435b16857c
diff --git a/dev-ml/uchar/metadata.xml b/dev-ml/uchar/metadata.xml
new file mode 100644
index 000000000000..0318635800e1
--- /dev/null
+++ b/dev-ml/uchar/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ocaml/uchar</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/uchar/uchar-0.0.2.ebuild b/dev-ml/uchar/uchar-0.0.2.ebuild
new file mode 100644
index 000000000000..41c83cb4f77b
--- /dev/null
+++ b/dev-ml/uchar/uchar-0.0.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib
+
+DESCRIPTION="Uchar compatibility library"
+HOMEPAGE="https://github.com/ocaml/uchar"
+SRC_URI="https://github.com/ocaml/uchar/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-4.03:="
+DEPEND="${RDEPEND} dev-ml/ocamlbuild"
+
+# This is mostly a compat wrapper for older ocaml versions we don't support. No
+# need to test it, plus it fails when installing for the first time:
+# https://bugs.gentoo.org/show_bug.cgi?id=624144
+RESTRICT="test"
+
+src_compile() {
+ ocaml pkg/build.ml \
+ "native=$(usex ocamlopt true false)" \
+ "native-dynlink=$(usex ocamlopt true false)" || die
+}
+
+src_test() {
+ ocamlbuild -X src -use-ocamlfind -pkg uchar test/testpkg.native || die
+}
+
+src_install() {
+ # Can't use opam-installer here as it is an opam dep...
+ findlib_src_preinst
+ mv _build/pkg/META{.empty,} || die
+ ocamlfind install ${PN} _build/pkg/META || die
+ dodoc README.md CHANGES.md
+}