summaryrefslogtreecommitdiff
path: root/dev-ml/uchar/uchar-0.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-ml/uchar/uchar-0.0.2.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/uchar/uchar-0.0.2.ebuild')
-rw-r--r--dev-ml/uchar/uchar-0.0.2.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-ml/uchar/uchar-0.0.2.ebuild b/dev-ml/uchar/uchar-0.0.2.ebuild
deleted file mode 100644
index 41c83cb4f77b..000000000000
--- a/dev-ml/uchar/uchar-0.0.2.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit findlib
-
-DESCRIPTION="Uchar compatibility library"
-HOMEPAGE="https://github.com/ocaml/uchar"
-SRC_URI="https://github.com/ocaml/uchar/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2-with-linking-exception"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
-IUSE="+ocamlopt"
-
-RDEPEND=">=dev-lang/ocaml-4.03:="
-DEPEND="${RDEPEND} dev-ml/ocamlbuild"
-
-# This is mostly a compat wrapper for older ocaml versions we don't support. No
-# need to test it, plus it fails when installing for the first time:
-# https://bugs.gentoo.org/show_bug.cgi?id=624144
-RESTRICT="test"
-
-src_compile() {
- ocaml pkg/build.ml \
- "native=$(usex ocamlopt true false)" \
- "native-dynlink=$(usex ocamlopt true false)" || die
-}
-
-src_test() {
- ocamlbuild -X src -use-ocamlfind -pkg uchar test/testpkg.native || die
-}
-
-src_install() {
- # Can't use opam-installer here as it is an opam dep...
- findlib_src_preinst
- mv _build/pkg/META{.empty,} || die
- ocamlfind install ${PN} _build/pkg/META || die
- dodoc README.md CHANGES.md
-}