summaryrefslogtreecommitdiff
path: root/dev-ml/tyxml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-21 13:54:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-21 13:54:09 +0000
commit454de691f3543d47dc89cd0b137eaa9ea4640cd3 (patch)
tree90ec469ff7d2e1b1fac0b0f98f32d49dacb30278 /dev-ml/tyxml
parente393c0503a79342594a61547dc43f80f8bcc086e (diff)
gentoo auto-resync : 21:12:2022 - 13:54:08
Diffstat (limited to 'dev-ml/tyxml')
-rw-r--r--dev-ml/tyxml/Manifest4
-rw-r--r--dev-ml/tyxml/files/tyxml-4.5.0-gentoo.patch11
-rw-r--r--dev-ml/tyxml/metadata.xml21
-rw-r--r--dev-ml/tyxml/tyxml-4.5.0.ebuild29
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-ml/tyxml/Manifest b/dev-ml/tyxml/Manifest
new file mode 100644
index 000000000000..5ebfa98180a3
--- /dev/null
+++ b/dev-ml/tyxml/Manifest
@@ -0,0 +1,4 @@
+AUX tyxml-4.5.0-gentoo.patch 376 BLAKE2B 433ef3124dfb6632aaa0dfceb048af905a4f70c98e94c2bf87570b9afb2775719cde532f024bf0509dcc93a12f18272c2df9c7d4a09e333c6a9b66563e0f02de SHA512 c3a3153c7416ec20f104d3b02c32bc3884254dc4e25e9da2eb83f72047306c4db2b852b1b4610dc37b9122e9dfb76ec89f6a8375e1583c35b28e36f9732229ae
+DIST tyxml-4.5.0.tbz 102918 BLAKE2B 28c5f827e6969ce9557a86c976e6925716f30759607a11c027c9c6a63c6078437c84ec565d03a91775223fbb9bef97f7acc0c0bb5677205c7e0af7be601b6e26 SHA512 772535441b09c393d53c27152e65f404a0a541aa0cea1bda899a8d751ab64d1729237e583618c3ff33d75e3865d53503d1ea413c6bbc8c68c413347efd1709b3
+EBUILD tyxml-4.5.0.ebuild 625 BLAKE2B c36bdec03ba03b727599f04f9041046e055eb907fc4f2adca5af46a2f42d0c8a591722e0f0fda555e3fda0220c70f553695bbfe2cb3e3fbf2467fc6b503a85c1 SHA512 85c4080b8815ca53128e53608bef84821f44891db69b230dc5545b539b304ee107a128313b1dea3171f68ff4a54973f8e7a8174b8ba83a3deb48772b01742a57
+MISC metadata.xml 864 BLAKE2B 3c101e5c42567dbde18863761f7c2647d8905866e1627c3ea740947324a8a4042a950aac46da39c96886e56e36c119787678e8f4c0a0146f9182c987b96bccaa SHA512 654eb0ff469280efb726d54b2979de2da080d86b5c5e5fd0c9f3b6d95aa7cb4141376e6d64819341762344372a00a294ec3f55eaa2d06dd965c0fdcacc524ca9
diff --git a/dev-ml/tyxml/files/tyxml-4.5.0-gentoo.patch b/dev-ml/tyxml/files/tyxml-4.5.0-gentoo.patch
new file mode 100644
index 000000000000..276b7dbc6f10
--- /dev/null
+++ b/dev-ml/tyxml/files/tyxml-4.5.0-gentoo.patch
@@ -0,0 +1,11 @@
+--- a/lib/dune 2022-12-20 22:46:07.612173538 +0100
++++ b/lib/dune 2022-12-20 22:46:17.811016202 +0100
+@@ -5,7 +5,7 @@
+ (modules_without_implementation
+ Xml_sigs Html_sigs Svg_sigs Html_types Svg_types)
+ (synopsis "Statically correct HTML and SVG documents (Functor version)")
+- (libraries uutf re seq)
++ (libraries uutf re)
+ (flags (:standard
+ -safe-string))
+ )
diff --git a/dev-ml/tyxml/metadata.xml b/dev-ml/tyxml/metadata.xml
new file mode 100644
index 000000000000..aed95d1077cd
--- /dev/null
+++ b/dev-ml/tyxml/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <longdescription>
+ TyXML provides a set of convenient combinators that uses the OCaml
+ type system to ensure the validity of the generated documents. TyXML
+ can be used with any representation of HTML and SVG: the textual one,
+ provided directly by this package, or DOM trees (js_of_ocaml-tyxml)
+ virtual DOM (virtual-dom) and reactive or replicated trees (eliom).
+ You can also create your own representation and use it to instantiate
+ a new set of combinators.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/ocsigen/tyxml/issues/</bugs-to>
+ <remote-id type="github">ocsigen/tyxml</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/tyxml/tyxml-4.5.0.ebuild b/dev-ml/tyxml/tyxml-4.5.0.ebuild
new file mode 100644
index 000000000000..192acf0b7965
--- /dev/null
+++ b/dev-ml/tyxml/tyxml-4.5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="A library for building correct HTML and SVG documents"
+HOMEPAGE="https://github.com/ocsigen/tyxml"
+SRC_URI="https://github.com/ocsigen/${PN}/releases/download/${PV}/${P}.tbz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ml/markup:=
+ dev-ml/ppxlib:=
+ dev-ml/uutf:=
+ dev-ml/re:="
+DEPEND="${RDEPEND}"
+BDEPEND="test? (
+ dev-ml/alcotest
+ dev-ml/reason
+)"
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )