summaryrefslogtreecommitdiff
path: root/dev-ml/trie
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-ml/trie
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-ml/trie')
-rw-r--r--dev-ml/trie/Manifest3
-rw-r--r--dev-ml/trie/metadata.xml13
-rw-r--r--dev-ml/trie/trie-1.0.0.ebuild15
3 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/trie/Manifest b/dev-ml/trie/Manifest
new file mode 100644
index 000000000000..09fb0781f53f
--- /dev/null
+++ b/dev-ml/trie/Manifest
@@ -0,0 +1,3 @@
+DIST trie-1.0.0.tar.gz 2399 BLAKE2B 3f58dbe33686baca2290a413b7d069b8d97ec69546217cefbb6404877b1fec129824da66fbbd6774e069285960ad9dc12380ecd828135ea50d86caa951e0df8b SHA512 1921a42486a0a221e546507287cbf28ccae5462abe55817269517b7b92e19f35031f2d0fba2b1890b97236d6fff11be9d76ade317ae1dfa1089bd4740a46786f
+EBUILD trie-1.0.0.ebuild 352 BLAKE2B ce4426c346c39d578b3f6120df2aa708f1b635f9799b82b66c143d1ff3e244526c3a251aba5191a07925471ad041274eeff7a5a7a6a7e862fab7e94cf83dfcf8 SHA512 86c43b75e60b29892f3a6484c775187d29a523fc69413fb621cb5baef556eb9aee3b1648d3575052dd48a382d5956303ba944201d999ea5192773872670961db
+MISC metadata.xml 379 BLAKE2B fb6bf43bcb3055bf1916ecfbe47bcd34ad2d20a5b3a7d39c71e2d84f4818839b84e8801b9f575a70ae80664aaca20a8b93f28a48e560cc5177bcd8e26caaa074 SHA512 1b87d0f3549c6c9eef190d6a03359431fd110a7256d984afb5967f9a7599c99bebe163d294911a800de3c12728ee7ea4e4bcba0bc23ed48d4482239aff0569d8
diff --git a/dev-ml/trie/metadata.xml b/dev-ml/trie/metadata.xml
new file mode 100644
index 000000000000..387e4466f6c3
--- /dev/null
+++ b/dev-ml/trie/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/kandu/trie/issues/</bugs-to>
+ <remote-id type="github">kandu/trie</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/trie/trie-1.0.0.ebuild b/dev-ml/trie/trie-1.0.0.ebuild
new file mode 100644
index 000000000000..d8539a79670d
--- /dev/null
+++ b/dev-ml/trie/trie-1.0.0.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Strict impure trie tree"
+HOMEPAGE="https://github.com/kandu/trie"
+SRC_URI="https://github.com/kandu/trie/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"