summaryrefslogtreecommitdiff
path: root/dev-ml/topkg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/topkg
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/topkg')
-rw-r--r--dev-ml/topkg/Manifest5
-rw-r--r--dev-ml/topkg/metadata.xml11
-rw-r--r--dev-ml/topkg/topkg-0.9.0.ebuild33
-rw-r--r--dev-ml/topkg/topkg-0.9.1.ebuild33
4 files changed, 82 insertions, 0 deletions
diff --git a/dev-ml/topkg/Manifest b/dev-ml/topkg/Manifest
new file mode 100644
index 000000000000..1d86b803b7ea
--- /dev/null
+++ b/dev-ml/topkg/Manifest
@@ -0,0 +1,5 @@
+DIST topkg-0.9.0.tar.gz 120352 BLAKE2B 1122fe8b60e3d104136810a2cec8460c24a26061eff55e80347d2ecf197afee949e8afaca94a6615da31a8c3acaf113b44b16dbf2430fda6724e440597775bb5 SHA512 823fe1abb344d7800e09411c952bd276ecea97b5d9c124d986e26b9128d03b3ad023a38560198e476ef8f949ecb456078e332bda94075e9b746e43d3059a8fdb
+DIST topkg-0.9.1.tar.gz 120943 BLAKE2B 39ac0d1d247183cf9f007c65b09d413ad6a89982d84269e99585ed5f15df4d7683de61548dba6ca5a1299f96206bfd2dc1042486410caa202938dc15e936446b SHA512 19773eb764b53a6e5110c44d7942d2557d6c8502a3037b57f7737efc08f4cc374845b431fdb1465207693d15a4b072aea3db97f8e60e069e3d24ae150e8c5c8f
+EBUILD topkg-0.9.0.ebuild 918 BLAKE2B 7609f6477f8526ac94c4a1993904d2c6ffcd76c8f3af7c13b8c92565c5150819ebf193f8c21ccc49bbc68864743b4675d99115ab25639bec37e7669d65f8eaba SHA512 9f2f36e01b23b079866b641e5c5109fee45fb89f40bdbd05c6a4aeb18cc028972416a1ee3d054494b084700a0233968717a6e1abb81f2fd84223833521feb489
+EBUILD topkg-0.9.1.ebuild 918 BLAKE2B 7609f6477f8526ac94c4a1993904d2c6ffcd76c8f3af7c13b8c92565c5150819ebf193f8c21ccc49bbc68864743b4675d99115ab25639bec37e7669d65f8eaba SHA512 9f2f36e01b23b079866b641e5c5109fee45fb89f40bdbd05c6a4aeb18cc028972416a1ee3d054494b084700a0233968717a6e1abb81f2fd84223833521feb489
+MISC metadata.xml 326 BLAKE2B b294ade664c113ffc2846e041ceaa6913a39dc402d671f01be9cf78b8304e6874d42c5067bb9fce104575d0cdbaa8b89d5ff6cfc3df0d164070a139d8ad59d4b SHA512 73f1d4965ba7b15a7ea5ad4382aeb1a6173c021d7f955080a69e5a77834b4dea4472b763ab598f234cc69a7d4c0b9beee0d5cbf9976cd258517eb316a9a6e92c
diff --git a/dev-ml/topkg/metadata.xml b/dev-ml/topkg/metadata.xml
new file mode 100644
index 000000000000..583ef1b56425
--- /dev/null
+++ b/dev-ml/topkg/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">dbuenzli/topkg</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/topkg/topkg-0.9.0.ebuild b/dev-ml/topkg/topkg-0.9.0.ebuild
new file mode 100644
index 000000000000..2cfed454c256
--- /dev/null
+++ b/dev-ml/topkg/topkg-0.9.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib
+
+DESCRIPTION="The transitory OCaml software packager"
+HOMEPAGE="http://erratique.ch/software/topkg https://github.com/dbuenzli/topkg"
+SRC_URI="https://github.com/dbuenzli/topkg/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-ml/result:=
+ dev-ml/ocamlbuild:=
+ dev-ml/findlib:=
+ dev-lang/ocaml:="
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ ocaml pkg/pkg.ml build --pkg-name ${PN} || die
+}
+
+src_install() {
+ # Can't use opam-installer here as it is an opam dep...
+ findlib_src_preinst
+ local nativelibs="$(echo _build/src/${PN}*.cm{x,xa,xs,ti} _build/src/${PN}.a)"
+ ocamlfind install ${PN} _build/pkg/META _build/src/${PN}.mli _build/src/${PN}.cm{a,i} ${nativelibs} || die
+ dodoc CHANGES.md DEVEL.md README.md
+}
diff --git a/dev-ml/topkg/topkg-0.9.1.ebuild b/dev-ml/topkg/topkg-0.9.1.ebuild
new file mode 100644
index 000000000000..2cfed454c256
--- /dev/null
+++ b/dev-ml/topkg/topkg-0.9.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib
+
+DESCRIPTION="The transitory OCaml software packager"
+HOMEPAGE="http://erratique.ch/software/topkg https://github.com/dbuenzli/topkg"
+SRC_URI="https://github.com/dbuenzli/topkg/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-ml/result:=
+ dev-ml/ocamlbuild:=
+ dev-ml/findlib:=
+ dev-lang/ocaml:="
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ ocaml pkg/pkg.ml build --pkg-name ${PN} || die
+}
+
+src_install() {
+ # Can't use opam-installer here as it is an opam dep...
+ findlib_src_preinst
+ local nativelibs="$(echo _build/src/${PN}*.cm{x,xa,xs,ti} _build/src/${PN}.a)"
+ ocamlfind install ${PN} _build/pkg/META _build/src/${PN}.mli _build/src/${PN}.cm{a,i} ${nativelibs} || die
+ dodoc CHANGES.md DEVEL.md README.md
+}