summaryrefslogtreecommitdiff
path: root/dev-ml/tiny_httpd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-30 20:59:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-30 20:59:34 +0000
commit182063dd85a03f2086258946276c8967945ffe95 (patch)
tree94440d3476f11273b5072685640990ec95042468 /dev-ml/tiny_httpd
parent268511f85b0606dd23fda1991345568dd3e1976b (diff)
gentoo auto-resync : 30:01:2023 - 20:59:33
Diffstat (limited to 'dev-ml/tiny_httpd')
-rw-r--r--dev-ml/tiny_httpd/Manifest3
-rw-r--r--dev-ml/tiny_httpd/files/tiny_httpd-0.12-noseq.patch11
-rw-r--r--dev-ml/tiny_httpd/tiny_httpd-0.12-r1.ebuild (renamed from dev-ml/tiny_httpd/tiny_httpd-0.12.ebuild)7
3 files changed, 17 insertions, 4 deletions
diff --git a/dev-ml/tiny_httpd/Manifest b/dev-ml/tiny_httpd/Manifest
index 47cc2a5724d9..be08a1c4171d 100644
--- a/dev-ml/tiny_httpd/Manifest
+++ b/dev-ml/tiny_httpd/Manifest
@@ -1,3 +1,4 @@
+AUX tiny_httpd-0.12-noseq.patch 300 BLAKE2B 15089d5aa2e596b4c2280ebc6762ea0ea65a121134abe02ec5f6abcefb9997e3fc9348825e2a95b1262a1d08df2cf24e22ec3d7beed770079301bc8f0a160869 SHA512 58dcac15a28d83c13345236cf502845962871c89d903a45a43b98cd66f9bf3865146d2fe16c5119d55fa129229729639ae26d3457d6cef2f2fd917c18c2ee495
DIST tiny_httpd-0.12.tar.gz 49124 BLAKE2B c3f407a605dabad1c710a696a3fca5dce04a75deb61e25e9ce572432e0d96cd3029628ea24d17d55a051d1d0f78aa1fd80797e7ff9c0bb7fc9d190e461784cd3 SHA512 99b4d01d4f4d138b122c689b8b3bc5043fc386d6686675311f625bf5fec72c6e1a7513712b00889fe17cd392b8c475440d4f89ee46392aff32ac6ccc39cefe09
-EBUILD tiny_httpd-0.12.ebuild 971 BLAKE2B fe9e0ef9dafc3fd1fd840aa4e507287b84d75f44774f0cc86464d9f5e8c5116c545405799a42bbd242b411143f7c9e9e000b9ce6b68b6aacd21d121cadf78fd5 SHA512 6c3b371cec555aa91d6e02d52ce17706771f03f762fb6aa6cf1fe719c0fac39896d3688fcc4fe1c4df0f9115869a3a68dbcacf496b3d45ef567fca386bdebc7d
+EBUILD tiny_httpd-0.12-r1.ebuild 1023 BLAKE2B 0119f754c56bd69886a79e43bc6921379679d50929b707bbe89006c885bfaeca495f2884134f30a2763d7a678a7425229fea140827941580d0fc3425d844c8b7 SHA512 96a007caebfd466133d2bf0428d3559949e19bae54f7fed6f26e575ac6d892d44460235ab4459ecd5e8d3fa58b6312ca9847e9a59ffb23214fef2915bcf8f50e
MISC metadata.xml 645 BLAKE2B d251040ed807f6fd6da65c22022e2586dc0fb369e3458943e8e9acf524f9a85222193301e228e9663d53f98b7fe778a6dc30f6acd66d4a817c22f85e742d6b34 SHA512 e82e86033f230b7e4912c464c13276728b062b31f53ec97181737a1e76cb52a3d43995449eff44cb187f37f611e391048971d0f62f524157c882ce7d87a8a58a
diff --git a/dev-ml/tiny_httpd/files/tiny_httpd-0.12-noseq.patch b/dev-ml/tiny_httpd/files/tiny_httpd-0.12-noseq.patch
new file mode 100644
index 000000000000..b35ba64f8d72
--- /dev/null
+++ b/dev-ml/tiny_httpd/files/tiny_httpd-0.12-noseq.patch
@@ -0,0 +1,11 @@
+--- a/src/dune 2023-01-30 20:28:23.578884847 +0100
++++ b/src/dune 2023-01-30 20:28:33.523713488 +0100
+@@ -2,7 +2,7 @@
+ (library
+ (name tiny_httpd)
+ (public_name tiny_httpd)
+- (libraries threads seq)
++ (libraries threads)
+ (flags :standard -safe-string -warn-error -a+8)
+ (wrapped false))
+
diff --git a/dev-ml/tiny_httpd/tiny_httpd-0.12.ebuild b/dev-ml/tiny_httpd/tiny_httpd-0.12-r1.ebuild
index 890d8831cf38..957cfe61d316 100644
--- a/dev-ml/tiny_httpd/tiny_httpd-0.12.ebuild
+++ b/dev-ml/tiny_httpd/tiny_httpd-0.12-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -18,9 +18,8 @@ KEYWORDS="~amd64"
IUSE="camlzip ocamlopt test"
RDEPEND="
+ >=dev-lang/ocaml-4.08
dev-ml/result:=
- dev-ml/seq:=
-
camlzip? ( >=dev-ml/camlzip-1.06:= )
"
DEPEND="
@@ -37,6 +36,8 @@ DEPEND="
RESTRICT="!test? ( test )"
REQUIRED_USE="test? ( camlzip )"
+PATCHES=( "${FILESDIR}"/${P}-noseq.patch )
+
src_compile() {
local pkgs="tiny_httpd"
use camlzip && pkgs="${pkgs},tiny_httpd_camlzip"