summaryrefslogtreecommitdiff
path: root/dev-ml/stdio/stdio-0.16.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-30 19:43:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-30 19:43:35 +0100
commitb7efdd771aad99c9a6509a5f85a80a1f7cfd55f3 (patch)
tree02f9d01894c5e75c1d01e1c85038384cb6d1da64 /dev-ml/stdio/stdio-0.16.0.ebuild
parente2e7cc7d880b593b2bc94bf648dff853c97225f2 (diff)
gentoo auto-resync : 30:06:2023 - 19:43:35
Diffstat (limited to 'dev-ml/stdio/stdio-0.16.0.ebuild')
-rw-r--r--dev-ml/stdio/stdio-0.16.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ml/stdio/stdio-0.16.0.ebuild b/dev-ml/stdio/stdio-0.16.0.ebuild
new file mode 100644
index 000000000000..171197bf5c82
--- /dev/null
+++ b/dev-ml/stdio/stdio-0.16.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Standard IO Library for OCaml"
+HOMEPAGE="https://github.com/janestreet/stdio"
+SRC_URI="https://github.com/janestreet/stdio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.14
+ dev-ml/base:${SLOT}
+"
+DEPEND="${RDEPEND}"