summaryrefslogtreecommitdiff
path: root/dev-ml/stdcompat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-10 09:27:33 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-10 09:27:33 +0000
commite80777b54c5b430ca044e16878f59a2020423d48 (patch)
treeb72b3422d129532b8f0ceb415c6e7c5109e3fe75 /dev-ml/stdcompat
parentaa61828f226f3b30e6939408847d914a145fdf35 (diff)
gentoo auto-resync : 10:11:2022 - 09:27:33
Diffstat (limited to 'dev-ml/stdcompat')
-rw-r--r--dev-ml/stdcompat/Manifest3
-rw-r--r--dev-ml/stdcompat/metadata.xml16
-rw-r--r--dev-ml/stdcompat/stdcompat-19.ebuild25
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/stdcompat/Manifest b/dev-ml/stdcompat/Manifest
new file mode 100644
index 000000000000..0294108f795a
--- /dev/null
+++ b/dev-ml/stdcompat/Manifest
@@ -0,0 +1,3 @@
+DIST stdcompat-19.tar.gz 530511 BLAKE2B 4af97c355b98f63366d647a4a375bde43ffbf959a2c02132ab57457db4213b8f98a972bf99667dd53603b28235b4f853470c2117270ce42c6aa579a21dd148fb SHA512 25582731170f2f80eed281c48af4904d1d00ef88a38d1b17853395c19a326d7b11e42c17b69f639402c467ff6f9b83a2e9d4dbab7255ac25d466b85a55674bd0
+EBUILD stdcompat-19.ebuild 619 BLAKE2B 70f8fbb535ecd3c682197f7ef3ac382a1b0efa6a837efb0938bbc8edf60972d52d3e7261c4271c409a20e5bff0a26abcef050bac6cee82f5fa7cdb400992b924 SHA512 6b2a837ef459d2c2f9678057cf39cf26c20e75932a84be552c9dd624b8e018ff006b6335abd0bc7ac41e0e24e8aa60049366300fdab64e0d84b50b1541e9ca43
+MISC metadata.xml 577 BLAKE2B b6857bd7760fbdc5988d1a545e2f128c9d13ea18d43a341af0757a227958594ed314b9472c9994fae54f7aba2f57ebee06b6f9cc4bb5a1428218dcdda2745507 SHA512 859f88d95b52a4e159fb4241ccaca2ba7777eda999623e281fd36e6b1ab2273407931f9ca89971f86b7563889bb704d7e353605f808aab868cb09a0468687419
diff --git a/dev-ml/stdcompat/metadata.xml b/dev-ml/stdcompat/metadata.xml
new file mode 100644
index 000000000000..ef295f228ea6
--- /dev/null
+++ b/dev-ml/stdcompat/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <longdescription lang="en">
+ Compatibility module for OCaml standard library allowing programs
+ to use some recent additions to the OCaml standard library while
+ preserving the ability to be compiled on former versions of OCaml.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">thierry-martinez/stdcompat</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/stdcompat/stdcompat-19.ebuild b/dev-ml/stdcompat/stdcompat-19.ebuild
new file mode 100644
index 000000000000..e6001579ae46
--- /dev/null
+++ b/dev-ml/stdcompat/stdcompat-19.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Compatibility module for OCaml standard library"
+HOMEPAGE="https://github.com/thierry-martinez/stdcompat"
+SRC_URI="https://github.com/thierry-martinez/stdcompat/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+SLOT="0/${PV}"
+
+DEPEND="dev-lang/ocaml:=[ocamlopt]
+ dev-ml/result:=[ocamlopt]
+ dev-ml/uchar:=[ocamlopt]"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-ml/dune
+ dev-ml/findlib[ocamlopt]"
+
+src_configure () {
+ econf --libdir="${EPREFIX}"/usr/$(get_libdir)/ocaml
+}