summaryrefslogtreecommitdiff
path: root/dev-ml/spawn/spawn-0.13.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
commitd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (patch)
tree1814dd2b5bbf2e7639fdafbeef48d228cfaf5e9b /dev-ml/spawn/spawn-0.13.0.ebuild
parentabaa75b10f899ada8dd05b23cc03205064394bc6 (diff)
gentoo resync : 29.01.2021
Diffstat (limited to 'dev-ml/spawn/spawn-0.13.0.ebuild')
-rw-r--r--dev-ml/spawn/spawn-0.13.0.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-ml/spawn/spawn-0.13.0.ebuild b/dev-ml/spawn/spawn-0.13.0.ebuild
new file mode 100644
index 000000000000..5dd601727870
--- /dev/null
+++ b/dev-ml/spawn/spawn-0.13.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Spawning sub-processes"
+HOMEPAGE="https://github.com/janestreet/spawn"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="ocamlopt test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-ml/ppx_expect )"