summaryrefslogtreecommitdiff
path: root/dev-ml/sexplib/sexplib-0.15.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-ml/sexplib/sexplib-0.15.0-r2.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-ml/sexplib/sexplib-0.15.0-r2.ebuild')
-rw-r--r--dev-ml/sexplib/sexplib-0.15.0-r2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ml/sexplib/sexplib-0.15.0-r2.ebuild b/dev-ml/sexplib/sexplib-0.15.0-r2.ebuild
new file mode 100644
index 000000000000..bd2b1329a0db
--- /dev/null
+++ b/dev-ml/sexplib/sexplib-0.15.0-r2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Library for automated conversion of OCaml-values to and from S-expressions"
+HOMEPAGE="https://github.com/janestreet/sexplib"
+SRC_URI="https://github.com/janestreet/sexplib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-ml/parsexp:=
+ dev-ml/base:=
+ dev-ml/sexplib0:=
+ dev-ml/num:=
+"
+DEPEND="${RDEPEND}"