summaryrefslogtreecommitdiff
path: root/dev-ml/sexp_pretty
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-28 14:51:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-28 14:51:38 +0000
commitd414c993cafd9e31a370c4a5aae042c710df2419 (patch)
treea4e123f32e84e3c7c7fdde2f083b1831f018bef6 /dev-ml/sexp_pretty
parent21dbcce41990b13f301240313be05c8d013a9258 (diff)
gentoo auto-resync : 28:01:2023 - 14:51:38
Diffstat (limited to 'dev-ml/sexp_pretty')
-rw-r--r--dev-ml/sexp_pretty/Manifest4
-rw-r--r--dev-ml/sexp_pretty/sexp_pretty-0.15.0-r1.ebuild (renamed from dev-ml/sexp_pretty/sexp_pretty-0.15.0.ebuild)4
-rw-r--r--dev-ml/sexp_pretty/sexp_pretty-0.15.1.ebuild26
3 files changed, 32 insertions, 2 deletions
diff --git a/dev-ml/sexp_pretty/Manifest b/dev-ml/sexp_pretty/Manifest
index 099307efe8d9..b282dc11b5ca 100644
--- a/dev-ml/sexp_pretty/Manifest
+++ b/dev-ml/sexp_pretty/Manifest
@@ -1,3 +1,5 @@
DIST sexp_pretty-0.15.0.tar.gz 22407 BLAKE2B df8d246ebe1164f0d2d3ae78074c8249d2aa255a089e02eb9fcc0c21b808dc172da2da264d3b21b92dcc7bf9e51a2921ea8631eb45b45a46035447ead7abe02d SHA512 bc2a7aecfc3ae379a56e8940b9cc80ece686009c9f67233e7993e25ebbe251d62559601923db718a0f967cf42fc84024597c069659842760bb2ac5ce0eab8df2
-EBUILD sexp_pretty-0.15.0.ebuild 490 BLAKE2B 1e579ee968b3621d64d6ad8f705d0d3ec3a6060da1b3abd87f6a611fe03f7b6aadae0928d2168ff47cf218aa91df734a928989ebe64a0dc2dad15f9fd2c6df2a SHA512 00c76ee6a4b4b62cb0c31c54137871225d41316f1f6e5ec872f9b4559f781d4380ab7e2691f8566d6f78487363d3529c720d4f27bd275405575b2bb78f9c9297
+DIST sexp_pretty-0.15.1.tar.gz 22410 BLAKE2B e3819bce21afb8addcf391aff7a330db7f332c338d11f87cf0264d0e8d45ead7897b881a646a908e6165e2b60b9d49c6f2cb4da26ef7f3402ddbc864ff6b088b SHA512 900accca43727f8e7603f21adb0b2bc5a121b1444112b152ed1bfd6ace553b3cd4b2f80371a8f924b636ea33cfa26e913bdcd0ab42e5af5fd24f21ecbca8e736
+EBUILD sexp_pretty-0.15.0-r1.ebuild 526 BLAKE2B 73891124ce6695ea1ca31026ce783350934b0efb56a0e6961b1c0d429c191dcf27f29c2f6928719357fe6dcc76bfb253fd9f14dfd97523b592e5de4a6f3d56c2 SHA512 46e65aeff23e710f19389faef93129750d82948caa7ad0d0f39aa9b9ce4a919bbffcdac65d98225245ace9f1a3f6477b075abb6cd7632ec5067076b4665e7a19
+EBUILD sexp_pretty-0.15.1.ebuild 526 BLAKE2B 73891124ce6695ea1ca31026ce783350934b0efb56a0e6961b1c0d429c191dcf27f29c2f6928719357fe6dcc76bfb253fd9f14dfd97523b592e5de4a6f3d56c2 SHA512 46e65aeff23e710f19389faef93129750d82948caa7ad0d0f39aa9b9ce4a919bbffcdac65d98225245ace9f1a3f6477b075abb6cd7632ec5067076b4665e7a19
MISC metadata.xml 320 BLAKE2B eb891c246afc84774ab5d03ec3048547c4bb0ef5058f82e8fe3ef172274e352acd868c21df8da52c99c419159b2b8c84fc1b4899b3e16703e5035f8baaddeac8 SHA512 2d3f66b309fa519afc0c4e4adc5fc38009130e7f8b2210517166e70998d628d1a17c7d869f29284ab6b1d53abfa2b872ca9c4289137fe4cbea35faec7e865d84
diff --git a/dev-ml/sexp_pretty/sexp_pretty-0.15.0.ebuild b/dev-ml/sexp_pretty/sexp_pretty-0.15.0-r1.ebuild
index a7320a57b1d9..df25c3ade56d 100644
--- a/dev-ml/sexp_pretty/sexp_pretty-0.15.0.ebuild
+++ b/dev-ml/sexp_pretty/sexp_pretty-0.15.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -17,6 +17,8 @@ IUSE="+ocamlopt"
DEPEND="
dev-ml/ppx_base:${SLOT}
+ dev-ml/ppx_hash:=
+ dev-ml/ppxlib:=
dev-ml/sexplib:${SLOT}
dev-ml/re:=
"
diff --git a/dev-ml/sexp_pretty/sexp_pretty-0.15.1.ebuild b/dev-ml/sexp_pretty/sexp_pretty-0.15.1.ebuild
new file mode 100644
index 000000000000..df25c3ade56d
--- /dev/null
+++ b/dev-ml/sexp_pretty/sexp_pretty-0.15.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="S-expression pretty-printer"
+HOMEPAGE="https://github.com/janestreet/sexp_pretty"
+SRC_URI="https://github.com/janestreet/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/ppx_base:${SLOT}
+ dev-ml/ppx_hash:=
+ dev-ml/ppxlib:=
+ dev-ml/sexplib:${SLOT}
+ dev-ml/re:=
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""