summaryrefslogtreecommitdiff
path: root/dev-ml/sexp_pretty
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-02 11:30:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-02 11:30:05 +0100
commit8164a4e49d69b936f2d820456e48468dc0e241ad (patch)
tree72c381896b721d4947b8f65f0cadceef779b99ae /dev-ml/sexp_pretty
parentc3ec60d8953748433a04137e04480e9c1a36ed4c (diff)
gentoo auto-resync : 02:07:2023 - 11:30:05
Diffstat (limited to 'dev-ml/sexp_pretty')
-rw-r--r--dev-ml/sexp_pretty/Manifest2
-rw-r--r--dev-ml/sexp_pretty/sexp_pretty-0.16.0.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/sexp_pretty/Manifest b/dev-ml/sexp_pretty/Manifest
index c3f2e7de00bc..6b60009e098c 100644
--- a/dev-ml/sexp_pretty/Manifest
+++ b/dev-ml/sexp_pretty/Manifest
@@ -1,5 +1,7 @@
DIST sexp_pretty-0.15.0.tar.gz 22407 BLAKE2B df8d246ebe1164f0d2d3ae78074c8249d2aa255a089e02eb9fcc0c21b808dc172da2da264d3b21b92dcc7bf9e51a2921ea8631eb45b45a46035447ead7abe02d SHA512 bc2a7aecfc3ae379a56e8940b9cc80ece686009c9f67233e7993e25ebbe251d62559601923db718a0f967cf42fc84024597c069659842760bb2ac5ce0eab8df2
DIST sexp_pretty-0.15.1.tar.gz 22410 BLAKE2B e3819bce21afb8addcf391aff7a330db7f332c338d11f87cf0264d0e8d45ead7897b881a646a908e6165e2b60b9d49c6f2cb4da26ef7f3402ddbc864ff6b088b SHA512 900accca43727f8e7603f21adb0b2bc5a121b1444112b152ed1bfd6ace553b3cd4b2f80371a8f924b636ea33cfa26e913bdcd0ab42e5af5fd24f21ecbca8e736
+DIST sexp_pretty-0.16.0.tar.gz 22557 BLAKE2B e44dbaaf18ffe8899ae636271110cccfeeb61e0284b321ee0d9865e0a8805df4a50540b526988c7f8f0d42092a036421b1e53122c6d22fb38d7ad4295c1055c8 SHA512 531c71dc77abfe9d088eb6213ae9d6563d9a6e1db58a710974120ece6465e192aab4ede6e36e12b6a386bbcfcfa497d5f7a5ac250ea54bdf641cbd597ffc96b6
EBUILD sexp_pretty-0.15.0-r1.ebuild 526 BLAKE2B 73891124ce6695ea1ca31026ce783350934b0efb56a0e6961b1c0d429c191dcf27f29c2f6928719357fe6dcc76bfb253fd9f14dfd97523b592e5de4a6f3d56c2 SHA512 46e65aeff23e710f19389faef93129750d82948caa7ad0d0f39aa9b9ce4a919bbffcdac65d98225245ace9f1a3f6477b075abb6cd7632ec5067076b4665e7a19
EBUILD sexp_pretty-0.15.1-r1.ebuild 582 BLAKE2B 8d203b4b0f7e26b0ed62713e8592d3a29fe84981132a26809f3316f9a3cdcc3adeadbfd94f419fc11aae0e7a6e492b370bf05efbe08e2b7b3efc2933ebf7c5d0 SHA512 c2d5876a8c79d449565efca79f6b83457a912a94f696dd6711f8b9b9c8c8ebc3262a0c50592bb7385a8c32bf7db6ae1eb3f32194e2d1041957e180c80c4c9c74
+EBUILD sexp_pretty-0.16.0.ebuild 609 BLAKE2B d24f6c39ebbd95c373e500bfbea4bc1570671a9c91eb501ee1f1d1f4853b736b3e94a325b567862b9c106313745a88ae702ca6b9b5b568ed8bcbca1590cffd85 SHA512 90d0c09b427e615d60206477c4f0b162dca377df1c024f7f3d47373d752736511d73d60e0e5c9fe81e01ab4d0c345deb8572d10be71de60b4b3a2af55d4aa56c
MISC metadata.xml 320 BLAKE2B eb891c246afc84774ab5d03ec3048547c4bb0ef5058f82e8fe3ef172274e352acd868c21df8da52c99c419159b2b8c84fc1b4899b3e16703e5035f8baaddeac8 SHA512 2d3f66b309fa519afc0c4e4adc5fc38009130e7f8b2210517166e70998d628d1a17c7d869f29284ab6b1d53abfa2b872ca9c4289137fe4cbea35faec7e865d84
diff --git a/dev-ml/sexp_pretty/sexp_pretty-0.16.0.ebuild b/dev-ml/sexp_pretty/sexp_pretty-0.16.0.ebuild
new file mode 100644
index 000000000000..76bb6484838f
--- /dev/null
+++ b/dev-ml/sexp_pretty/sexp_pretty-0.16.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="S-expression pretty-printer"
+HOMEPAGE="https://github.com/janestreet/sexp_pretty"
+SRC_URI="https://github.com/janestreet/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-lang/ocaml-4.14
+ dev-ml/ppxlib:=
+ dev-ml/ppx_base:${SLOT}
+ dev-ml/ppx_enumerate:=
+ dev-ml/ppx_hash:=
+ dev-ml/re:=
+ dev-ml/sexplib:${SLOT}
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""