summaryrefslogtreecommitdiff
path: root/dev-ml/sexp_pretty
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-ml/sexp_pretty
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-ml/sexp_pretty')
-rw-r--r--dev-ml/sexp_pretty/Manifest3
-rw-r--r--dev-ml/sexp_pretty/metadata.xml11
-rw-r--r--dev-ml/sexp_pretty/sexp_pretty-0.15.0.ebuild24
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-ml/sexp_pretty/Manifest b/dev-ml/sexp_pretty/Manifest
new file mode 100644
index 000000000000..099307efe8d9
--- /dev/null
+++ b/dev-ml/sexp_pretty/Manifest
@@ -0,0 +1,3 @@
+DIST sexp_pretty-0.15.0.tar.gz 22407 BLAKE2B df8d246ebe1164f0d2d3ae78074c8249d2aa255a089e02eb9fcc0c21b808dc172da2da264d3b21b92dcc7bf9e51a2921ea8631eb45b45a46035447ead7abe02d SHA512 bc2a7aecfc3ae379a56e8940b9cc80ece686009c9f67233e7993e25ebbe251d62559601923db718a0f967cf42fc84024597c069659842760bb2ac5ce0eab8df2
+EBUILD sexp_pretty-0.15.0.ebuild 490 BLAKE2B 1e579ee968b3621d64d6ad8f705d0d3ec3a6060da1b3abd87f6a611fe03f7b6aadae0928d2168ff47cf218aa91df734a928989ebe64a0dc2dad15f9fd2c6df2a SHA512 00c76ee6a4b4b62cb0c31c54137871225d41316f1f6e5ec872f9b4559f781d4380ab7e2691f8566d6f78487363d3529c720d4f27bd275405575b2bb78f9c9297
+MISC metadata.xml 320 BLAKE2B eb891c246afc84774ab5d03ec3048547c4bb0ef5058f82e8fe3ef172274e352acd868c21df8da52c99c419159b2b8c84fc1b4899b3e16703e5035f8baaddeac8 SHA512 2d3f66b309fa519afc0c4e4adc5fc38009130e7f8b2210517166e70998d628d1a17c7d869f29284ab6b1d53abfa2b872ca9c4289137fe4cbea35faec7e865d84
diff --git a/dev-ml/sexp_pretty/metadata.xml b/dev-ml/sexp_pretty/metadata.xml
new file mode 100644
index 000000000000..7b8d25489544
--- /dev/null
+++ b/dev-ml/sexp_pretty/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">janestreet/sexp_pretty</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/sexp_pretty/sexp_pretty-0.15.0.ebuild b/dev-ml/sexp_pretty/sexp_pretty-0.15.0.ebuild
new file mode 100644
index 000000000000..a7320a57b1d9
--- /dev/null
+++ b/dev-ml/sexp_pretty/sexp_pretty-0.15.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="S-expression pretty-printer"
+HOMEPAGE="https://github.com/janestreet/sexp_pretty"
+SRC_URI="https://github.com/janestreet/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/ppx_base:${SLOT}
+ dev-ml/sexplib:${SLOT}
+ dev-ml/re:=
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""