summaryrefslogtreecommitdiff
path: root/dev-ml/seq
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
commitb24bd25253fe093f722ab576d29fdc41d04cb1ee (patch)
tree0fcf2afd9f852c4d4c291cf8afaa2c244d598105 /dev-ml/seq
parent121ed4eec41fbf03e1998d09eede1bf449da63b9 (diff)
gentoo resync : 02.08.2019
Diffstat (limited to 'dev-ml/seq')
-rw-r--r--dev-ml/seq/Manifest4
-rw-r--r--dev-ml/seq/files/seq-0.1-gentoo.patch10
-rw-r--r--dev-ml/seq/metadata.xml11
-rw-r--r--dev-ml/seq/seq-0.1.ebuild32
4 files changed, 57 insertions, 0 deletions
diff --git a/dev-ml/seq/Manifest b/dev-ml/seq/Manifest
new file mode 100644
index 000000000000..4f5009c8d1ab
--- /dev/null
+++ b/dev-ml/seq/Manifest
@@ -0,0 +1,4 @@
+AUX seq-0.1-gentoo.patch 309 BLAKE2B c80895e464359e67350ee3f0a183f3dfde63d718775876acad3905446c62dac229ad173b334020f4b2d51807b37d15e526ea98fd3ce2bf27ee8fe751c77c6d11 SHA512 0f93ed7035bc7138518b99471d64cf6144cfd3d4aeb08445a7fc6b2ae631a96a242a1dceaa5014b6503149ad24a1f048c1f0ea435ff38e8c76452f0bafffe540
+DIST seq-0.1.tar.gz 2452 BLAKE2B 4f673c3909611957fc882c548c8549cbcad1e93101e1968f001609108b89f4cee13b055a7a8e75e9c36d33074863532b7d84461f036d14c468d5baadde411295 SHA512 cf0df428408efd8f593765c419007c3b181c1234fa957bd09bd96bbbbc7950dcd329429a8a22573680fdfd46847e21befae29ade967509690428ba2b90fe83f2
+EBUILD seq-0.1.ebuild 627 BLAKE2B 1d3b7e89ceee19d671d3b80a20b367e1a040e07fbb51262f837936ca6cccfb5ca30f1d45274ebb845a322e2a2c5286996cf43fb10a36ffbaa2dcd806bd3dfb77 SHA512 016c0ec96d2eebf9045105365af0d4a3a60ece2211373f758f52b5932278c92387fb43a84873aadffa86303e50db34d6a35a79fd820f6aaa8249d271ac902fc8
+MISC metadata.xml 375 BLAKE2B c6d166cdc6fbcce412dd0f1d78f8d1f54635d25c89e12d762e0f967a85c1a315c4912a58cdf8075c784881dcb507594d73cec30cd09e575877696a17b616d868 SHA512 dc49b250f3706af5b0f3a589bace4bd06c900d6d5f0551ae311090985c4267592a385c007f09423be4a37793e00cbe8275aa1faeee2df7f6858f67260cbd7932
diff --git a/dev-ml/seq/files/seq-0.1-gentoo.patch b/dev-ml/seq/files/seq-0.1-gentoo.patch
new file mode 100644
index 000000000000..1b3de2b9c12f
--- /dev/null
+++ b/dev-ml/seq/files/seq-0.1-gentoo.patch
@@ -0,0 +1,10 @@
+--- a/Makefile 2019-07-21 21:17:32.334645928 +0200
++++ b/Makefile 2019-07-21 21:18:28.565894767 +0200
+@@ -9,6 +9,6 @@
+ TOINSTALL=$(wildcard _build/src/*)
+
+ install:
+- ocamlfind install seq META $(TOINSTALL)
++ ocamlfind install -destdir $(DESTDIR)@LIBDIR@ seq META $(TOINSTALL)
+
+ .PHONY: build clean install
diff --git a/dev-ml/seq/metadata.xml b/dev-ml/seq/metadata.xml
new file mode 100644
index 000000000000..4b96cb1315b7
--- /dev/null
+++ b/dev-ml/seq/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <longdescription lang="en">
+ Compatibility package for OCaml's standard iterator type starting from 4.07.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-ml/seq/seq-0.1.ebuild b/dev-ml/seq/seq-0.1.ebuild
new file mode 100644
index 000000000000..3a5b9b4aa827
--- /dev/null
+++ b/dev-ml/seq/seq-0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Compatibility package for the standard OCaml iterator type"
+HOMEPAGE="https://github.com/c-cube/seq"
+SRC_URI="https://github.com/c-cube/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-ml/ocamlbuild"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s:@LIBDIR@:/usr/$(get_libdir)/ocaml:" \
+ Makefile \
+ || die
+}
+
+src_install() {
+ dodir /usr/$(get_libdir)/ocaml
+ default
+}