summaryrefslogtreecommitdiff
path: root/dev-ml/reason-parser/reason-parser-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/reason-parser/reason-parser-2.0.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/reason-parser/reason-parser-2.0.0.ebuild')
-rw-r--r--dev-ml/reason-parser/reason-parser-2.0.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/reason-parser/reason-parser-2.0.0.ebuild b/dev-ml/reason-parser/reason-parser-2.0.0.ebuild
new file mode 100644
index 000000000000..2ec81a735441
--- /dev/null
+++ b/dev-ml/reason-parser/reason-parser-2.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib eutils opam
+
+DESCRIPTION="Meta Language Toolchain"
+HOMEPAGE="https://github.com/facebook/reason"
+SRC_URI="https://github.com/facebook/reason/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-ml/menhir-20170418:=
+ dev-ml/merlin-extend:=
+ dev-ml/result:=
+ dev-ml/topkg:=
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/ppx_tools_versioned:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/ocamlbuild
+"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ emake compile_error
+ ocamlbuild -package topkg pkg/build.native || die
+ ./build.native build \
+ --native "$(usex ocamlopt true false)" \
+ --native-dynlink "$(usex ocamlopt true false)" \
+ || die
+}