summaryrefslogtreecommitdiff
path: root/dev-ml/react/react-1.2.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-ml/react/react-1.2.1-r1.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-ml/react/react-1.2.1-r1.ebuild')
-rw-r--r--dev-ml/react/react-1.2.1-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/react/react-1.2.1-r1.ebuild b/dev-ml/react/react-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..8f19e9401a65
--- /dev/null
+++ b/dev-ml/react/react-1.2.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit opam
+
+DESCRIPTION="OCaml module for functional reactive programming"
+HOMEPAGE="http://erratique.ch/software/react https://github.com/dbuenzli/react"
+SRC_URI="http://erratique.ch/software/react/releases/${P}.tbz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+ >=dev-ml/topkg-0.9
+"
+
+src_compile() {
+ ocaml pkg/pkg.ml build \
+ --tests $(usex test 'true' 'false') \
+ || die
+}
+
+src_test() {
+ ocaml pkg/pkg.ml test || die
+}