summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_string
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-ml/ppx_string
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-ml/ppx_string')
-rw-r--r--dev-ml/ppx_string/Manifest3
-rw-r--r--dev-ml/ppx_string/metadata.xml11
-rw-r--r--dev-ml/ppx_string/ppx_string-0.14.1.ebuild26
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-ml/ppx_string/Manifest b/dev-ml/ppx_string/Manifest
new file mode 100644
index 000000000000..5501f53afe13
--- /dev/null
+++ b/dev-ml/ppx_string/Manifest
@@ -0,0 +1,3 @@
+DIST ppx_string-0.14.1.tar.gz 4807 BLAKE2B 2ce5cf2d5dd913f05e66c24ea5be2ce4a56c59b7e5faecf003a573274bfaef3834935276e110fba1d0af3a3ef9d6ca730622dc780ab6063945a01aa3d6900a43 SHA512 2b570ca3d248f89ee1903e6ea40fbcd9c5c72809ff1f42dc67e9d41f6c297465ae47ffdbeda9f263dddf14c9c460bbbdee01243cef838d0ec49493c3b5644aee
+EBUILD ppx_string-0.14.1.ebuild 658 BLAKE2B 76abf940a0c46be6466c2cd416dd04a3f446da8cca2154efa8faf390557e14c9573d91031976672baeed787b1b9421032dc4673ed7ce1cd055bdd7ebddd09083 SHA512 03462b3aa6e4eb5e827a4f4249f37557694e2581c2865f343ce3323d5a03862648cc9f3cea6ee540ae2aaade2b8646e2d31d36806a766710dc02d99a9e4ed45e
+MISC metadata.xml 330 BLAKE2B 8a254f960154cdca219a8a0839d20a0b1b59499050aad7a319a14ea9d25488ae8f831522f06ad207e2b54d67ada15c3f8a55ac31fcfff24bbdb7d7992c371681 SHA512 039ca9055143f9795534cb4c0092f6618b7f091e0cef20cd2e831a67318ac20ce7fcc0118f45058c8f4665ca30585f6e6ec87f3a65fabd27dc9d4f3433ed1eb3
diff --git a/dev-ml/ppx_string/metadata.xml b/dev-ml/ppx_string/metadata.xml
new file mode 100644
index 000000000000..1350c31c1a0c
--- /dev/null
+++ b/dev-ml/ppx_string/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gienah@gentoo.org</email>
+ <name>Mark Wright</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">janestreet/ppx_string</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ppx_string/ppx_string-0.14.1.ebuild b/dev-ml/ppx_string/ppx_string-0.14.1.ebuild
new file mode 100644
index 000000000000..da70fa07c084
--- /dev/null
+++ b/dev-ml/ppx_string/ppx_string-0.14.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Ppx extension for string interpolation"
+HOMEPAGE="https://github.com/janestreet/ppx_string"
+SRC_URI="https://github.com/janestreet/ppx_string/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-ml/base-0.14.0:=
+ >=dev-ml/ppx_base-0.14.0:=
+ >=dev-ml/ppxlib-0.18.0:=
+ >=dev-ml/ocaml-compiler-libs-0.11.0:=
+ >=dev-ml/ocaml-migrate-parsetree-2.0.0:=
+ dev-ml/cinaps:=
+ >=dev-ml/stdio-0.14.0:=
+"
+RDEPEND="${DEPEND}"