summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.15.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-28 14:51:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-28 14:51:38 +0000
commitd414c993cafd9e31a370c4a5aae042c710df2419 (patch)
treea4e123f32e84e3c7c7fdde2f083b1831f018bef6 /dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.15.0-r2.ebuild
parent21dbcce41990b13f301240313be05c8d013a9258 (diff)
gentoo auto-resync : 28:01:2023 - 14:51:38
Diffstat (limited to 'dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.15.0-r2.ebuild')
-rw-r--r--dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.15.0-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.15.0-r2.ebuild b/dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.15.0-r2.ebuild
new file mode 100644
index 000000000000..a31de8e54ea4
--- /dev/null
+++ b/dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.15.0-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Support Library for type-driven code generators"
+HOMEPAGE="https://github.com/janestreet/ppx_sexp_conv"
+SRC_URI="https://github.com/janestreet/ppx_sexp_conv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+# Upper bound on ppxlib for bug #769536
+DEPEND="
+ dev-ml/base:${SLOT}
+ dev-ml/findlib:=
+ >=dev-ml/ppxlib-0.23:=
+ <dev-ml/ppxlib-0.26
+ >=dev-ml/ocaml-compiler-libs-0.11.0:=
+"
+RDEPEND="${DEPEND}"