summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.2.ebuild
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.2.ebuild')
-rw-r--r--dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.2.ebuild b/dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.2.ebuild
new file mode 100644
index 000000000000..0779d1b88a06
--- /dev/null
+++ b/dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Support Library for type-driven code generators"
+HOMEPAGE="https://github.com/janestreet/ppx_sexp_conv"
+SRC_URI="https://github.com/janestreet/ppx_sexp_conv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+# Upper bound on ppxlib for bug #769536
+DEPEND="
+ >=dev-ml/base-0.14.0:=
+ dev-ml/findlib:=
+ >=dev-ml/ppxlib-0.18.0:=
+ <=dev-ml/ppxlib-0.20.0:=
+ >=dev-ml/ocaml-compiler-libs-0.11.0:=
+ >=dev-ml/ocaml-migrate-parsetree-2.0.0:=
+ dev-ml/cinaps:=
+ dev-ml/sexplib0:=
+"
+RDEPEND="${DEPEND}"