summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_optional
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ml/ppx_optional
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ml/ppx_optional')
-rw-r--r--dev-ml/ppx_optional/Manifest3
-rw-r--r--dev-ml/ppx_optional/metadata.xml11
-rw-r--r--dev-ml/ppx_optional/ppx_optional-0.9.0.ebuild24
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-ml/ppx_optional/Manifest b/dev-ml/ppx_optional/Manifest
new file mode 100644
index 000000000000..463a059c7774
--- /dev/null
+++ b/dev-ml/ppx_optional/Manifest
@@ -0,0 +1,3 @@
+DIST ppx_optional-0.9.0.tar.gz 6940 SHA256 4f9cae512eab8c3457329d9ca0655f8ea9ca0d1465ceb7d13734e0972912d6f2 SHA512 c341bc8e64b7caf7af5c878747697330db84b14959f22930dd6919cc861dce847983771cbad2ed7800ab8c64704e88fa0d8db3ca7c8f2924bf785a4dccd17fa0 WHIRLPOOL 2abb146131f62d7f8da17bd67bdeaf30ac495a3ac63ccd3506c81aa20f1287671ece5cd20e6fae7fa3e1177b4e6b6e0b10fb4252b623455134a0d708c6c1859b
+EBUILD ppx_optional-0.9.0.ebuild 541 SHA256 c5c02c64d469e74979ae5e8cc7bb2e90a8549a65730a261d1ffd92faeb46e4ae SHA512 3f085f451459dfa4f66fe38d85f5288adf02d16d939a080686d83d7bbed4b839aa2f9ec73b37c09718c9158b3f86259ae893e7d6a98469bcd21b6eba0d158dc9 WHIRLPOOL 54f7835f0821f414fc34223052a52106cc096231ce7e86f9200ed6366fa9dfbda5e8b8beccd1616bc1606be4665e4374f52f1e5c09bab7a07ecc0b3fa2998fbe
+MISC metadata.xml 335 SHA256 1c23df28b4db6d3631ea0a98dea983986da28cdcfac15e6a765727231b907450 SHA512 f744f3a7baf77bec288c64156d624c46e1d93e40f0dcff8d2a11e3f2981717f4043c49a5af2acb4118b46557e41f35f940923196b03d3ddc5021e0d65c3f849f WHIRLPOOL bd93400bc59e5df46f1763820653b2ab8c27b3d04b4b6e9b7725e65325adc9b6161d212e5a66c29415a4979b3906e680467fadf5740528f36cb0d53eef4bc80a
diff --git a/dev-ml/ppx_optional/metadata.xml b/dev-ml/ppx_optional/metadata.xml
new file mode 100644
index 000000000000..548e15439c5d
--- /dev/null
+++ b/dev-ml/ppx_optional/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">janestreet/ppx_optional</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ppx_optional/ppx_optional-0.9.0.ebuild b/dev-ml/ppx_optional/ppx_optional-0.9.0.ebuild
new file mode 100644
index 000000000000..55a77ef14936
--- /dev/null
+++ b/dev-ml/ppx_optional/ppx_optional-0.9.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit opam
+
+DESCRIPTION="Pattern matching on flat options"
+HOMEPAGE="https://github.com/janestreet/ppx_optional"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-ml/ppx_core:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_metaquot:=
+ dev-ml/ocaml-migrate-parsetree:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/jbuilder"