summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_metaquot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ml/ppx_metaquot
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ml/ppx_metaquot')
-rw-r--r--dev-ml/ppx_metaquot/Manifest3
-rw-r--r--dev-ml/ppx_metaquot/metadata.xml11
-rw-r--r--dev-ml/ppx_metaquot/ppx_metaquot-0.9.0.ebuild25
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/ppx_metaquot/Manifest b/dev-ml/ppx_metaquot/Manifest
new file mode 100644
index 000000000000..2c27a89db02d
--- /dev/null
+++ b/dev-ml/ppx_metaquot/Manifest
@@ -0,0 +1,3 @@
+DIST ppx_metaquot-0.9.0.tar.gz 6801 SHA256 28eeb135afd697c8a6591023129f518be05c8ab71d661c1f6e5ca732644b367e SHA512 7645f02f964f2a33836f947a725384f95c7724dcd88c031aa3dd2d255127a21d473e19ff77cb917f845930ab44541a4698becf56721cc1a0a0eee5912947cd22 WHIRLPOOL 17ff0c79e08a58f3587b57fbe2c283e3c4cd51e6011d99a576b407b91679959ce1055bae99c40319a98747b1c463b334a54169fd5e0511d2607ba8f2f2333bf2
+EBUILD ppx_metaquot-0.9.0.ebuild 589 SHA256 a8a116f0c33bdb337db575e0e2ade986575f183c9d875f57d47a8d6ed4705046 SHA512 556ab9b9f108a6523fb93249f6874a3f80fb3bcdf942bbad35b2ec324fd3291c081d76c9f20dcf8313b24fe8a294b8165691d4db53eaa5d00119145cda74f52e WHIRLPOOL 1289006f1a5f8225b61ae641e127cd48d686b53eaab05d7cd762c961378051fdfd2a138789f032a9f4f4ecc0435c46591c5ff8e5f6b807ff2a0ddd4550a2146f
+MISC metadata.xml 334 SHA256 f0406ee18702ef1bf4b965610cbf2b256289332e3f467e3cf06fe28932e50f4c SHA512 b0da02ca604cfbccd08ba912893517438ad2bf0b43d4f78b601b26a443400015f294dc8589a60f54e04458189c3e6d77fd34f221daad139079eae895c6d49bf2 WHIRLPOOL a1a39560ce75d96d4093dae57538ebab5d071c779eb8f2e174ce0f4186353d0f04e0b98b636a7d616e32768d01fde60e5a2ce034ec95723c42abc0c24f875b0c
diff --git a/dev-ml/ppx_metaquot/metadata.xml b/dev-ml/ppx_metaquot/metadata.xml
new file mode 100644
index 000000000000..12b5d625b73e
--- /dev/null
+++ b/dev-ml/ppx_metaquot/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+</maintainer>
+ <upstream>
+ <remote-id type="github">janestreet/ppx_metaquot</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ppx_metaquot/ppx_metaquot-0.9.0.ebuild b/dev-ml/ppx_metaquot/ppx_metaquot-0.9.0.ebuild
new file mode 100644
index 000000000000..940de0b51a71
--- /dev/null
+++ b/dev-ml/ppx_metaquot/ppx_metaquot-0.9.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit opam
+
+DESCRIPTION="Write OCaml AST fragment using OCaml syntax"
+HOMEPAGE="https://github.com/janestreet/ppx_metaquot"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc"
+IUSE=""
+
+DEPEND="
+ dev-ml/ppx_core:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_traverse_builtins:=
+ dev-ml/ocaml-migrate-parsetree:=
+ <dev-ml/ppx_core-100
+ "
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/jbuilder"