summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_js_style
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-ml/ppx_js_style
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-ml/ppx_js_style')
-rw-r--r--dev-ml/ppx_js_style/Manifest4
-rw-r--r--dev-ml/ppx_js_style/metadata.xml5
-rw-r--r--dev-ml/ppx_js_style/ppx_js_style-0.14.0.ebuild26
3 files changed, 33 insertions, 2 deletions
diff --git a/dev-ml/ppx_js_style/Manifest b/dev-ml/ppx_js_style/Manifest
index f8de163b70e2..fd1037e39070 100644
--- a/dev-ml/ppx_js_style/Manifest
+++ b/dev-ml/ppx_js_style/Manifest
@@ -1,3 +1,5 @@
+DIST ppx_js_style-0.14.0.tar.gz 10587 BLAKE2B 8219a69526be53b9fce488f725c79ff30c451c556853aa54d8dbbd7040a76df37ac8942ae05cdcbbe6d839a64d5b471f53a2fce276e547a17e68490c1ec1ab19 SHA512 3561b7668bafc421fa82c3c80e019185924bfc8cafab6ef81299395061db78261005bdd34be5bed8a80bec84306b9294e6398a3a1ee0a269f7b8f3942953a6a4
DIST ppx_js_style-0.9.0.tar.gz 8182 BLAKE2B e2c4bffb07882d49f3839b2a402e2617b9e19147a0d4ff4c7aa4fb4a350d2208eccd76ec64828c4d56edce8f811c462396aa805ca3440b93ba22790d59c8dd23 SHA512 9790223a2d8f6db090cfa4d7ff3d3d1c8a22b07863dd3c5674216836b23cfdb3b014ebc092e173ddfe725ccf73fc7830a8a88effab1df9d80875f918b9558051
+EBUILD ppx_js_style-0.14.0.ebuild 645 BLAKE2B c20e910432824d5f1dd69ea8e59946d72a6eafe1772a6486c0c15f419d28621fa433c0212584244266fc93eee50ef0bb423a9ec45e27a5f18a8b62712b878226 SHA512 4d1dcec54676cd578c3ccfeeb6def21f70abd8208a2be52a2b1eada4e997168f1fb8ab7571de1c039c47036bcba1a3101ee4cdcdb8cfe37a77bfc177e059a41e
EBUILD ppx_js_style-0.9.0.ebuild 582 BLAKE2B 53c693c0bfdf52c14b48e4e60bc5ea791ff7c416b4bb60e45aed57ef15624e07fb2a60a2caaeaca0461d3093fdbdb3678540587654b5669bce40e92f90213d09 SHA512 c6a9d80217ae323e284be7244f38955495a852168de81c5e9137d1a470f2e8ab5b2e670c37bf88fcc8f7953a56b4fba17d7854bfcad101bd5964055d3f2f528d
-MISC metadata.xml 255 BLAKE2B 4f41fadc22d799cdcc1893a032a715aeadcb03f05de157a0a787102e0c294b4ac0eab1996aa07c97215c7cdf7de78e0af2ab1b3d98b530d3b2b490f6aade8379 SHA512 b0e6ea4682d3b7dd76f0eaed62f80ddccc3f360a021601b98a9f3fb22dadf6040d13d9f21c8edef638421365b1aca34c0adec0669c8ac7ab8481111334b706f0
+MISC metadata.xml 332 BLAKE2B 2efc9a64be7da306761ea6261393aa5a6f00d658668791e30f83fd13effcc70d5c3ecea46a49534e38cb9e02402ca9b1d17a699ed1d85ece1177da815048c47d SHA512 8abe379a3bf4e2212ec8566b9ab5fa6f82f5ca522953e12019f97b15c090f05b090a3364f39b62103a3c75c8a4493a7a4a9a112b0cb3acba7677cbd385e2f486
diff --git a/dev-ml/ppx_js_style/metadata.xml b/dev-ml/ppx_js_style/metadata.xml
index 3272a51e2cff..0d5d7a713ab7 100644
--- a/dev-ml/ppx_js_style/metadata.xml
+++ b/dev-ml/ppx_js_style/metadata.xml
@@ -1,7 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>gienah@gentoo.org</email>
+ <name>Mark Wright</name>
+ </maintainer>
<upstream>
<remote-id type="github">janestreet/ppx_js_style</remote-id>
</upstream>
diff --git a/dev-ml/ppx_js_style/ppx_js_style-0.14.0.ebuild b/dev-ml/ppx_js_style/ppx_js_style-0.14.0.ebuild
new file mode 100644
index 000000000000..a515f55da5e5
--- /dev/null
+++ b/dev-ml/ppx_js_style/ppx_js_style-0.14.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Code style checker for Jane Street Packages"
+HOMEPAGE="https://github.com/janestreet/ppx_js_style"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-ml/base-0.14.0:=
+ dev-ml/findlib:=
+ dev-ml/octavius:=
+ >=dev-ml/ppxlib-0.18.0:=
+ >=dev-ml/ocaml-compiler-libs-0.11.0:=
+ >=dev-ml/ocaml-migrate-parsetree-2.0.0:=
+ dev-ml/cinaps:=
+ "
+RDEPEND="${DEPEND}"