summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_js_style
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/ppx_js_style
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/ppx_js_style')
-rw-r--r--dev-ml/ppx_js_style/Manifest3
-rw-r--r--dev-ml/ppx_js_style/metadata.xml11
-rw-r--r--dev-ml/ppx_js_style/ppx_js_style-0.9.0.ebuild25
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/ppx_js_style/Manifest b/dev-ml/ppx_js_style/Manifest
new file mode 100644
index 000000000000..99442da70b22
--- /dev/null
+++ b/dev-ml/ppx_js_style/Manifest
@@ -0,0 +1,3 @@
+DIST ppx_js_style-0.9.0.tar.gz 8182 BLAKE2B e2c4bffb07882d49f3839b2a402e2617b9e19147a0d4ff4c7aa4fb4a350d2208eccd76ec64828c4d56edce8f811c462396aa805ca3440b93ba22790d59c8dd23 SHA512 9790223a2d8f6db090cfa4d7ff3d3d1c8a22b07863dd3c5674216836b23cfdb3b014ebc092e173ddfe725ccf73fc7830a8a88effab1df9d80875f918b9558051
+EBUILD ppx_js_style-0.9.0.ebuild 582 BLAKE2B 53c693c0bfdf52c14b48e4e60bc5ea791ff7c416b4bb60e45aed57ef15624e07fb2a60a2caaeaca0461d3093fdbdb3678540587654b5669bce40e92f90213d09 SHA512 c6a9d80217ae323e284be7244f38955495a852168de81c5e9137d1a470f2e8ab5b2e670c37bf88fcc8f7953a56b4fba17d7854bfcad101bd5964055d3f2f528d
+MISC metadata.xml 335 BLAKE2B 0d29994d7d7ca3c159264f75ba89f9774d8c59be7aa27f44bc18d1a0d21d6ed909e2f66f9c22931f463ba5ddf2d4144f986cfbc9d3a357eb8a0135eb339c268a SHA512 a8b814146208b31af8c1b4ba22b9eeb9461ab218b192910eafb0cd3ff6b2c734e9c14d7b4d52845e5338e7def081674d3c9fabbf7bd085648f9e9800a933bc5c
diff --git a/dev-ml/ppx_js_style/metadata.xml b/dev-ml/ppx_js_style/metadata.xml
new file mode 100644
index 000000000000..36b1bbb4dbed
--- /dev/null
+++ b/dev-ml/ppx_js_style/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">janestreet/ppx_js_style</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ppx_js_style/ppx_js_style-0.9.0.ebuild b/dev-ml/ppx_js_style/ppx_js_style-0.9.0.ebuild
new file mode 100644
index 000000000000..4e4459887d20
--- /dev/null
+++ b/dev-ml/ppx_js_style/ppx_js_style-0.9.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit opam
+
+DESCRIPTION="Code style checker for Jane Street Packages"
+HOMEPAGE="https://github.com/janestreet/ppx_js_style"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="
+ dev-ml/ppx_core:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_metaquot:=
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/octavius:=
+ "
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/jbuilder"