summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_import
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/ppx_import
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/ppx_import')
-rw-r--r--dev-ml/ppx_import/Manifest3
-rw-r--r--dev-ml/ppx_import/metadata.xml11
-rw-r--r--dev-ml/ppx_import/ppx_import-1.2.ebuild39
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-ml/ppx_import/Manifest b/dev-ml/ppx_import/Manifest
new file mode 100644
index 000000000000..7769f40166e1
--- /dev/null
+++ b/dev-ml/ppx_import/Manifest
@@ -0,0 +1,3 @@
+DIST ppx_import-1.2.tar.gz 13244 BLAKE2B 538fd11e151d740c601ca88ff682bf4ea84ddaea3fbbc5b54d43310e59baf00ae47ef397763861da8ff1b2af017bb318ec1cd48f8708b9dc2a2c68bf812e1aea SHA512 384a8f955573c66962383f0e3609e4764cb0056e7d5b7e5811fd9fd17e17ac58baea330131b8eb688cd4202d6e6bd5829fba024524f027201244ff10c86e0f01
+EBUILD ppx_import-1.2.ebuild 877 BLAKE2B 8461593cafa856c1ee4710d4a3e0d838169f5597852124069a27781f11e6a1a22f9c6c742990b805a9e2b8c65be18ac75b96cc262ace8e141704d0c644bc3712 SHA512 d870567695e3c7c985c8ddde4f1d2def0385a5520ff2d7cafa85d8c243faeb5ccef63aca2cb83d5952c8c3cee82ffa1098900cc8edf623662c35123f25909021
+MISC metadata.xml 333 BLAKE2B 80948000319ca0b20d03d6105879c81b543c0b009e23d16cc3cb677e670be50cfd6454d44bf02de44744c2b9d3d44e683272f5635d44c37e4171baebb5cd0cbe SHA512 d05450e13d2cfa74a954322f90489d4e990b44fc7756fbad01c74a7baf450593dc012b919c9781ba9d79b831835f41f9783eeb1c6049e668a1122a14bb2aefc5
diff --git a/dev-ml/ppx_import/metadata.xml b/dev-ml/ppx_import/metadata.xml
new file mode 100644
index 000000000000..d0bba00f86b8
--- /dev/null
+++ b/dev-ml/ppx_import/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">whitequark/ppx_import</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ppx_import/ppx_import-1.2.ebuild b/dev-ml/ppx_import/ppx_import-1.2.ebuild
new file mode 100644
index 000000000000..efecbd3f7200
--- /dev/null
+++ b/dev-ml/ppx_import/ppx_import-1.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit opam
+
+DESCRIPTION="A syntax extension for importing declarations from interface files"
+HOMEPAGE="https://github.com/whitequark/ppx_import"
+SRC_URI="https://github.com/whitequark/ppx_import/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt test"
+
+DEPEND="
+ dev-lang/ocaml:=[ocamlopt?]
+ dev-ml/ppx_tools:=
+ dev-ml/cppo:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ test? ( dev-ml/ounit dev-ml/ppx_deriving )
+ dev-ml/ocamlbuild
+ dev-ml/findlib
+"
+
+src_compile() {
+ cp pkg/META.in pkg/META
+ ocaml pkg/build.ml \
+ native=$(usex ocamlopt true false) \
+ native-dynlink=$(usex ocamlopt true false) \
+ || die
+}
+
+src_test() {
+ ocamlbuild -classic-display -use-ocamlfind src_test/test_ppx_import.byte -- || die
+}