summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_import/ppx_import-1.9.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-ml/ppx_import/ppx_import-1.9.1.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-ml/ppx_import/ppx_import-1.9.1.ebuild')
-rw-r--r--dev-ml/ppx_import/ppx_import-1.9.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/ppx_import/ppx_import-1.9.1.ebuild b/dev-ml/ppx_import/ppx_import-1.9.1.ebuild
new file mode 100644
index 000000000000..19b0da3ed57f
--- /dev/null
+++ b/dev-ml/ppx_import/ppx_import-1.9.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="A syntax extension for importing declarations from interface files"
+HOMEPAGE="https://github.com/ocaml-ppx/ppx_import/"
+SRC_URI="https://github.com/ocaml-ppx/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-ml/ppxlib:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ dev-ml/ounit2
+ dev-ml/ppx_deriving
+ dev-ml/ppx_sexp_conv
+ )
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-dune-ounit2.patch )