summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_import/ppx_import-1.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-28 14:51:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-28 14:51:38 +0000
commitd414c993cafd9e31a370c4a5aae042c710df2419 (patch)
treea4e123f32e84e3c7c7fdde2f083b1831f018bef6 /dev-ml/ppx_import/ppx_import-1.10.0.ebuild
parent21dbcce41990b13f301240313be05c8d013a9258 (diff)
gentoo auto-resync : 28:01:2023 - 14:51:38
Diffstat (limited to 'dev-ml/ppx_import/ppx_import-1.10.0.ebuild')
-rw-r--r--dev-ml/ppx_import/ppx_import-1.10.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/ppx_import/ppx_import-1.10.0.ebuild b/dev-ml/ppx_import/ppx_import-1.10.0.ebuild
new file mode 100644
index 000000000000..7e7bd09535f8
--- /dev/null
+++ b/dev-ml/ppx_import/ppx_import-1.10.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="A syntax extension for importing declarations from interface files"
+HOMEPAGE="https://github.com/ocaml-ppx/ppx_import/"
+SRC_URI="https://github.com/ocaml-ppx/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-ml/ppxlib-0.26:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ dev-ml/ounit2
+ dev-ml/ppx_deriving
+ dev-ml/ppx_sexp_conv
+ )
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-dune-ounit2.patch )