summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_fields_conv/ppx_fields_conv-0.14.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-ml/ppx_fields_conv/ppx_fields_conv-0.14.1.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-ml/ppx_fields_conv/ppx_fields_conv-0.14.1.ebuild')
-rw-r--r--dev-ml/ppx_fields_conv/ppx_fields_conv-0.14.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ml/ppx_fields_conv/ppx_fields_conv-0.14.1.ebuild b/dev-ml/ppx_fields_conv/ppx_fields_conv-0.14.1.ebuild
new file mode 100644
index 000000000000..2d1108cc9703
--- /dev/null
+++ b/dev-ml/ppx_fields_conv/ppx_fields_conv-0.14.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Generation of accessor and iteration functions for ocaml records"
+HOMEPAGE="https://github.com/janestreet/ppx_fields_conv"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-ml/base-0.14.0:=
+ >=dev-ml/fieldslib-0.14.0:=
+ >=dev-ml/ppxlib-0.18.0:=
+ >=dev-ml/ocaml-migrate-parsetree-2.0.0:=
+ dev-ml/cinaps:=
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-ppxlib-0.18.0.patch )