summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_custom_printf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ml/ppx_custom_printf
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ml/ppx_custom_printf')
-rw-r--r--dev-ml/ppx_custom_printf/Manifest4
-rw-r--r--dev-ml/ppx_custom_printf/metadata.xml11
-rw-r--r--dev-ml/ppx_custom_printf/ppx_custom_printf-0.9.0-r1.ebuild27
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-ml/ppx_custom_printf/Manifest b/dev-ml/ppx_custom_printf/Manifest
new file mode 100644
index 000000000000..2400fe242129
--- /dev/null
+++ b/dev-ml/ppx_custom_printf/Manifest
@@ -0,0 +1,4 @@
+DIST ppx_custom_printf-0.9.0.tar.gz 11527 SHA256 9c3c4be548d11a9b87f6a29bdc7bcf5509b4f20de5c309cf331ce45dcf314f8f SHA512 7608e09aac26f4f51d124d30c25a510abb73bea606007524a5563f5bb2c0e71f1ff033edb32c48f0c69656e8c3924b57186639812b1a647ce31f7ae15dc466cb WHIRLPOOL 729c03f257cb6edbb29ada1ed07f1f23952d5d369e2cf1b75700d01a24997a7f862228947256b729b20957614bf505ee878d576d90595ede0bf66480c7867803
+EBUILD ppx_custom_printf-0.9.0-r1.ebuild 645 SHA256 b77eac7fcb5940c608a99c5e47aeada4e450beb6f5831c836a8937a3839c1231 SHA512 258cdc49534126c7c5c26d03c927be5132d55b1b99fb76a3c62925df6c45a542e15dbcdaf6597349005a2b7d5a58ee157384f078aedf8367572db46d9af9bd11 WHIRLPOOL a4075d0ea3dd6fc3481f51034053eb49f31ab4507e00e5adb738f4c57994dfbafb6da3c4297b29217e34b6c7eca666db894596c0b81bbe119edd4391c88dc84d
+MISC ChangeLog 887 SHA256 a772f004eb79f7e7387a10ec569229d13e11918104236051961438a1d9306670 SHA512 7589dd21853b08ae469bd04bedda6c87fe4ecf6c8ffa10e4e463b46f62e35b122b6829350384fdcab025fdec793249fa7461654ab9478243cbd1dc47feeade87 WHIRLPOOL f56cd11c02cda139eb42adfaf12ce5775bea50b91d9aac2e3e3c7b15904797fe70fe1bd6420a74c158c6877321b02a1926a7b4cf76bdd4e10887137309a89b01
+MISC metadata.xml 340 SHA256 1c21af0dd98af938f9bc50a5c7236d9102552a510be18bd0da7801c81266f3ff SHA512 7e8f6ba90d2e6c5ed5871cfc52ab362ac42fbffbb83c43318f63d988b959799e0a08f8ec07d5c4f58eb875d980c38bc9d5f9c806ee0cf4f7ac4823a78d3cf25f WHIRLPOOL 4cde89f30558fabb41f6ed821d476723a3e70545842dd1a206e60b007a76076461fa5626cbf522033dc98db80de107602852fec4ceea0898c0536cf5d452a175
diff --git a/dev-ml/ppx_custom_printf/metadata.xml b/dev-ml/ppx_custom_printf/metadata.xml
new file mode 100644
index 000000000000..5fc614cb73f4
--- /dev/null
+++ b/dev-ml/ppx_custom_printf/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">janestreet/ppx_custom_printf</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ppx_custom_printf/ppx_custom_printf-0.9.0-r1.ebuild b/dev-ml/ppx_custom_printf/ppx_custom_printf-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..0ed35963b467
--- /dev/null
+++ b/dev-ml/ppx_custom_printf/ppx_custom_printf-0.9.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit opam
+
+DESCRIPTION="Printf-style format-strings for user-defined string conversion"
+HOMEPAGE="https://github.com/janestreet/ppx_custom_printf"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-ml/ppx_core:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_metaquot:=
+ dev-ml/ppx_sexp_conv:=
+ dev-ml/ppx_type_conv:=
+ dev-ml/ppx_traverse
+ dev-ml/ocaml-migrate-parsetree:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/jbuilder"