summaryrefslogtreecommitdiff
path: root/dev-ml/postgresql-ocaml/postgresql-ocaml-4.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ml/postgresql-ocaml/postgresql-ocaml-4.0.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ml/postgresql-ocaml/postgresql-ocaml-4.0.1.ebuild')
-rw-r--r--dev-ml/postgresql-ocaml/postgresql-ocaml-4.0.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/postgresql-ocaml/postgresql-ocaml-4.0.1.ebuild b/dev-ml/postgresql-ocaml/postgresql-ocaml-4.0.1.ebuild
new file mode 100644
index 000000000000..abe5b03fa5cc
--- /dev/null
+++ b/dev-ml/postgresql-ocaml/postgresql-ocaml-4.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="A package for ocaml that provides access to PostgreSQL databases"
+SRC_URI="https://github.com/mmottl/postgresql-ocaml/releases/download/v${PV}/${P}.tar.gz"
+HOMEPAGE="http://mmottl.github.io/postgresql-ocaml/"
+IUSE="examples"
+
+RDEPEND="
+ dev-db/postgresql:=[server]
+"
+DEPEND="${RDEPEND}
+ >=dev-ml/findlib-1.5"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc x86"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}