summaryrefslogtreecommitdiff
path: root/dev-ml/parmap/parmap-1.2.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-16 15:36:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-16 15:36:38 +0000
commit39fcd539b9eeb7df75bccad136265b5f001d1a3c (patch)
treefcedf7eec512b29edce8c642c52f834b2e15b4f8 /dev-ml/parmap/parmap-1.2.5.ebuild
parentb982051e7c8e12c3810a0d21d30d687b406b3ae5 (diff)
gentoo auto-resync : 16:12:2022 - 15:36:37
Diffstat (limited to 'dev-ml/parmap/parmap-1.2.5.ebuild')
-rw-r--r--dev-ml/parmap/parmap-1.2.5.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ml/parmap/parmap-1.2.5.ebuild b/dev-ml/parmap/parmap-1.2.5.ebuild
new file mode 100644
index 000000000000..6f83ebfb5b0b
--- /dev/null
+++ b/dev-ml/parmap/parmap-1.2.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+MY_PV="${PV/_/-}"
+DESCRIPTION="Library to exploit multicore architectures for OCaml programs"
+HOMEPAGE="https://www.dicosmo.org/code/parmap/"
+SRC_URI="https://github.com/rdicosmo/parmap/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV/+/-}"
+
+LICENSE="LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+BDEPEND="dev-ml/dune-configurator:="
+RDEPEND=">=dev-lang/ocaml-4.03:=[ocamlopt?]"
+DEPEND="${RDEPEND}"