summaryrefslogtreecommitdiff
path: root/dev-ml/ounit2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-ml/ounit2
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-ml/ounit2')
-rw-r--r--dev-ml/ounit2/Manifest3
-rw-r--r--dev-ml/ounit2/metadata.xml11
-rw-r--r--dev-ml/ounit2/ounit2-2.2.3.ebuild22
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-ml/ounit2/Manifest b/dev-ml/ounit2/Manifest
new file mode 100644
index 000000000000..6e6638e460b8
--- /dev/null
+++ b/dev-ml/ounit2/Manifest
@@ -0,0 +1,3 @@
+DIST ounit-v2.2.3.tbz 57449 BLAKE2B cf4742c4800ff66551416e243285ae0264f94d1665f795039cd37ad717b09fa3ba5cdfb2380169dfcddea5a27a82373ae892adf11155147a081d734091bf39d8 SHA512 dff04859d263e5f80a1606156d07493d0320a2756d0a7f134c63c53078550c7b056587486922bc66a288413af30c59a7e47157636502c6dd10626cf75587f981
+EBUILD ounit2-2.2.3.ebuild 508 BLAKE2B 9177e5e6a4eaeffea07555e65b7998aaf3fd7678459cfd5b6a19e53f1d5ad60957156ef112adbd36a30894fcd40bcb692a490a189742ea310009cfb49f55c2b1 SHA512 46d354956d9218076bcf3d06ed8e52c1b2bd9480139ac500e1a4c8a50ed5a3a6e697153da42bc5c23920f7ef88a2201fa914815d07d99389c49ebf589fa6a88b
+MISC metadata.xml 324 BLAKE2B c449d9ce329170cbebc09d1d471261f181b5e7af06e527a395f85b34d5f017b8abc0ec1af1b479d43821b622acafdfad6f2630198b6a64486698ab1d58f9635e SHA512 0f47266f1a7c530341f2e048889f26df9da2830eeceac36efb5c7077c48c124c964e7443ad1bc6876aa4b82807b43584bce5fc4706074c8faf379c9c2d0628b4
diff --git a/dev-ml/ounit2/metadata.xml b/dev-ml/ounit2/metadata.xml
new file mode 100644
index 000000000000..3084165d7481
--- /dev/null
+++ b/dev-ml/ounit2/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gienah@gentoo.org</email>
+ <name>Mark Wright</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">gildor478/ounit</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ounit2/ounit2-2.2.3.ebuild b/dev-ml/ounit2/ounit2-2.2.3.ebuild
new file mode 100644
index 000000000000..354af513eda9
--- /dev/null
+++ b/dev-ml/ounit2/ounit2-2.2.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Unit testing framework for OCaml"
+HOMEPAGE="https://github.com/gildor478/ounit"
+SRC_URI="https://github.com/gildor478/ounit/releases/download/v${PV}/ounit-v${PV}.tbz"
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+DEPEND="
+ dev-ml/lwt:=
+ dev-ml/stdlib-shims:=
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+IUSE="+ocamlopt"
+
+S="${WORKDIR}/ounit-v${PV}"