summaryrefslogtreecommitdiff
path: root/dev-ml/ounit2/ounit2-2.2.7-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-02 00:07:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-02 00:07:23 +0100
commit6657c680376cedf378fcf328e5fa03ed3b41d580 (patch)
tree44ea8d174f647daca562b9bdcbcb527a85a77d0a /dev-ml/ounit2/ounit2-2.2.7-r1.ebuild
parent1551fe56fd6ba43a94509cffc61b6bf854b7ac9f (diff)
gentoo auto-resync : 02:06:2024 - 00:07:23
Diffstat (limited to 'dev-ml/ounit2/ounit2-2.2.7-r1.ebuild')
-rw-r--r--dev-ml/ounit2/ounit2-2.2.7-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/ounit2/ounit2-2.2.7-r1.ebuild b/dev-ml/ounit2/ounit2-2.2.7-r1.ebuild
new file mode 100644
index 000000000000..bdddc585f018
--- /dev/null
+++ b/dev-ml/ounit2/ounit2-2.2.7-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Unit testing framework for OCaml"
+HOMEPAGE="https://github.com/gildor478/ounit"
+SRC_URI="https://github.com/gildor478/ounit/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/ounit-${PV}"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/lwt:=
+ dev-ml/stdlib-shims:=
+"
+RDEPEND="${DEPEND}"
+BDEPEND=">=dev-ml/dune-3"
+
+PATCHES=( "${FILESDIR}/${PN}-2.2.7-dune.patch" )
+
+src_install() {
+ dune-install ${PN} ${PN}-lwt
+}