summaryrefslogtreecommitdiff
path: root/dev-ml/ounit2/ounit2-2.2.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-ml/ounit2/ounit2-2.2.6.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-ml/ounit2/ounit2-2.2.6.ebuild')
-rw-r--r--dev-ml/ounit2/ounit2-2.2.6.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ml/ounit2/ounit2-2.2.6.ebuild b/dev-ml/ounit2/ounit2-2.2.6.ebuild
new file mode 100644
index 000000000000..b454e94dc082
--- /dev/null
+++ b/dev-ml/ounit2/ounit2-2.2.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Unit testing framework for OCaml"
+HOMEPAGE="https://github.com/gildor478/ounit"
+SRC_URI="https://github.com/gildor478/ounit/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/ounit-${PV}"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/lwt:=
+ dev-ml/stdlib-shims:=
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dune-install ${PN} ${PN}-lwt
+}