summaryrefslogtreecommitdiff
path: root/dev-ml/ordering
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-20 01:01:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-20 01:01:31 +0000
commit5d0c0ffd63620a4db788484bd36ab92b76e7891b (patch)
treeb4204d122504a5c2d3bfdb2cc9f3a5dcf5fe07b2 /dev-ml/ordering
parent60945053af0588a6219a4a6867aace9e7b47faeb (diff)
gentoo auto-resync : 20:11:2022 - 01:01:31
Diffstat (limited to 'dev-ml/ordering')
-rw-r--r--dev-ml/ordering/Manifest3
-rw-r--r--dev-ml/ordering/metadata.xml11
-rw-r--r--dev-ml/ordering/ordering-3.0.3.ebuild32
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-ml/ordering/Manifest b/dev-ml/ordering/Manifest
new file mode 100644
index 000000000000..153a15f4ec1d
--- /dev/null
+++ b/dev-ml/ordering/Manifest
@@ -0,0 +1,3 @@
+DIST dune-3.0.3.tar.gz 1725788 BLAKE2B 2de93c085f642c8381642a08b18bc21ad48097f32397b3eddab9725deb267b089849b649705e1b72bb1b5b37f7531fd9e0cfb134174f0cb3a8ee2595c7dcf8ce SHA512 839e942bcf8189763d0d9b01614333bb2f036bce68c82959e51d2e9145b57067cb862b66781912391c1a0f531b8dddf2ffeafcee71c626169a437fe40feba155
+EBUILD ordering-3.0.3.ebuild 705 BLAKE2B bc801175013b3c105f9539e0061c22830f53f6b8c2091e3e06b73edc50a9fe6dd4810a848b6f299b80829b7b1034b2c50b52b8a720442f3da27295f05df504db SHA512 e0ace6c90e7b83d20298f4d77910479fffb19b6fa1f7bccd7a6df8d76f7f61f82005789d1aed26cf798b318e71d28b04d6d02838ec21da2985c8d29411a124e3
+MISC metadata.xml 308 BLAKE2B 555692890c7fe4dee18d07e140384b70278e2a4a0230916a01ab9e5306776e0ed0d979e9a3487423fa1779a166da3038dca13273811e36593bb2b821b60cdfe0 SHA512 e50e28cb6f41fda295f12af1b94aba12dda8a7091322c0e7093d19ee60615d449bc1806354043e572d70aff1284e16b644b188911adbca60a2a5c8299fcee748
diff --git a/dev-ml/ordering/metadata.xml b/dev-ml/ordering/metadata.xml
new file mode 100644
index 000000000000..86dc156e664c
--- /dev/null
+++ b/dev-ml/ordering/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ocaml/dune</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ordering/ordering-3.0.3.ebuild b/dev-ml/ordering/ordering-3.0.3.ebuild
new file mode 100644
index 000000000000..0c02ad290b06
--- /dev/null
+++ b/dev-ml/ordering/ordering-3.0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune multiprocessing
+
+DESCRIPTION="Element ordering"
+HOMEPAGE="https://github.com/ocaml/dune"
+SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz -> dune-${PV}.tar.gz"
+S="${WORKDIR}/dune-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+BDEPEND="~dev-ml/dune-${PV}"
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ ./configure \
+ --libdir="$(ocamlc -where)" \
+ --mandir="/usr/share/man" \
+ || die
+}
+
+src_compile() {
+ dune build -p "${PN}" @install -j $(makeopts_jobs) --profile release || die
+}